
<!doctype html>
<html lang="en">
<head>
<link href="https://cdn.realpython.com" rel="preconnect">
<link href="https://files.realpython.com" rel="preconnect">
<title>Advanced Visual Studio Code for Python Developers – Real Python</title>
<meta name="author" content="Real Python">
<meta name="description" content="In this tutorial, you&#x27;ll learn how you can configure, extend, and optimize Visual Studio Code for a more effective and productive Python development environment. By digging into this customizable code editor and IDE, you&#x27;ll put yourself on track to be a VS Code power user.">
<meta name="keywords" content="">
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no, viewport-fit=cover">
<link rel="stylesheet" href="https://cdn.realpython.com/static/realpython.min.7472b7320c54.css">
<link rel="stylesheet" href="https://cdn.realpython.com/static/gfonts/font.08e909e5f3d4.css">
<link rel="preload" href="https://cdn.realpython.com/static/glightbox.min.f69035b3cab2.css" as="style" onload="this.onload=null;this.rel='stylesheet'"><noscript><link rel="stylesheet" href="https://cdn.realpython.com/static/glightbox.min.f69035b3cab2.css"></noscript>
<link rel="canonical" href="https://realpython.com/advanced-visual-studio-code-python/">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg">
<meta property="og:image" content="https://files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg">
<meta name="twitter:creator" content="@realpython">
<meta name="twitter:site" content="@realpython">
<meta property="og:title" content="Advanced Visual Studio Code for Python Developers – Real Python">
<meta property="og:type" content="article">
<meta property="og:url" content="https://realpython.com/advanced-visual-studio-code-python/">
<meta property="og:description" content="In this tutorial, you&#x27;ll learn how you can configure, extend, and optimize Visual Studio Code for a more effective and productive Python development environment. By digging into this customizable code editor and IDE, you&#x27;ll put yourself on track to be a VS Code power user.">
<link href="https://cdn.realpython.com/static/favicon.68cbf4197b0c.png" rel="icon">
<link href="https://realpython.com/atom.xml" rel="alternate" title="Real Python" type="application/atom+xml">
<link rel="manifest" href="/manifest.json">
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-35184939-1', 'auto', {'allowLinker': true});

  

  

  
  
  ga('set', {
    dimension1: false,
    dimension2: false
  });
  

  ga('send', 'pageview');
  
</script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<nav class="navbar fixed-top navbar-expand-lg navbar-dark flex-column ">
<div class="container flex-row">
<a class="navbar-brand" href="/">
<img src="https://cdn.realpython.com/static/real-python-logo.893c30edea53.svg" width="165" height="40" class="d-inline-block align-top" alt="Real Python">
</a>
<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbarSupportedContent" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>
<div class="collapse navbar-collapse navbar-nav-scroll" id="navbarSupportedContent" role="navigation" aria-label="Main Navigation">
<ul class="navbar-nav mr-2 flex-fill">
<li class="nav-item">
<a class="nav-link" href="/start-here/">Start&nbsp;Here</a>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownLibrary" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
<span class="fa fa-graduation-cap" aria-hidden="true"></span> Learn Python
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownLibrary">
<a class="dropdown-item" href="/" style="color: #ff7e73; line-height: 110%;"><i class="fa fa-fw mr-1 fa-graduation-cap" aria-hidden="true"></i> Python Tutorials →<br><small class="text-secondary">In-depth articles and tutorials</small></a>
<a class="dropdown-item" href="/courses/" style="color: #abe5b1; line-height: 110%;"><i class="fa fa-fw mr-1 fa-film" aria-hidden="true"></i> Video Courses →<br><small class="text-secondary">Step-by-step video lessons</small></a>
<a class="dropdown-item" href="/quizzes/" style="color: #abe0e5; line-height: 110%;"><i class="fa fa-fw mr-1 fa-trophy" aria-hidden="true"></i> Quizzes →<br><small class="text-secondary">Check your learning progress</small></a>
<a class="dropdown-item" href="/learning-paths/" style="color: #ffc873; line-height: 110%;"><i class="fa fa-fw mr-1 fa-map-o" aria-hidden="true"></i> Learning Paths →<br><small class="text-secondary">Guided study plans for accelerated learning</small></a>
<a class="dropdown-item" href="/community/" style="color: #e5c6ab; line-height: 110%;"><i class="fa fa-fw mr-1 fa-slack" aria-hidden="true"></i> Community →<br><small class="text-secondary">Learn with other Pythonistas</small></a>
<a class="dropdown-item pb-3" href="/tutorials/all/" style="color: #b8abe5; line-height: 110%;"><i class="fa fa-fw mr-1 fa-tags" aria-hidden="true"></i> Topics →<br><small class="text-secondary">Focus on a specific area or skill level</small></a>
<a class="dropdown-item border-top" href="/account/join/"><i class="fa fa-fw fa-star text-warning" aria-hidden="true"></i> Unlock All Content</a>
</div>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownBooksCourses" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Store
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownBooksCourses">
<a class="dropdown-item" href="/account/join/"><i class="fa fa-fw fa-star text-warning" aria-hidden="true"></i> RP Membership</a>
<a class="dropdown-item" href="/products/python-basics-book/">Python Basics Book</a>
<a class="dropdown-item" href="/products/python-tricks-book/">Python Tricks Book</a>
<a class="dropdown-item" href="/products/cpython-internals-book/">CPython Internals Book</a>
<a class="dropdown-item" href="/products/real-python-course/">The Real Python Course</a>
<a class="dropdown-item" href="/products/managing-python-dependencies/">Managing Python Dependencies</a>
<a class="dropdown-item" href="/products/sublime-python/">Sublime Text + Python Setup</a>
<a class="dropdown-item" href="/products/pythonic-wallpapers/">Pythonic Wallpapers Pack</a>
<a class="dropdown-item" href="https://nerdlettering.com" target="_blank">Python Mugs, T-Shirts, and More</a>
<a class="dropdown-item" href="https://www.pythonistacafe.com" target="_blank">Pythonista Cafe Community</a>
<a class="dropdown-item border-top" href="/products/">Browse All »</a>
</div>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMore" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
More
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMore">
<a class="dropdown-item" href="/newsletter/">Python Newsletter</a>
<a class="dropdown-item" href="/podcasts/rpp/">Python Podcast</a>
<a class="dropdown-item" href="https://www.pythonjobshq.com" target="_blank">Python Job Board</a>
<a class="dropdown-item" href="/team/">Meet the Team</a>
<a class="dropdown-item" href="/write-for-us/">Become a Tutorial Author</a>
<a class="dropdown-item" href="/become-an-instructor/">Become a Video Instructor</a>
</div>
</li>
</ul>
<div class="d-block d-xl-none">
<ul class="navbar-nav">
<li class="nav-item">
<a class="nav-link" href="/search" title="Search"><span class="d-block d-lg-none"><i class="fa fa-search" aria-hidden="true"></i> Search</span><span class="d-none d-lg-block"><i class="fa fa-search" aria-hidden="true"></i></span></a>
</li>
</ul>
</div>
<div class="d-none d-xl-flex align-items-center mr-2">
<form class="form-inline" action="/search" method="GET">
<a class="js-search-form-submit position-absolute" href="/search" title="Search"><i class="fa fa-search fa-fw text-muted pl-2" aria-hidden="true"></i></a>
<input class="search-field form-control form-control-md mr-sm-1 mr-lg-2 w-100" style="padding-left: 2rem;" maxlength=50 type="search" placeholder="Search" aria-label="Search" name="q">
<input type="hidden" name="_from" value="nav">
</form>
</div>
<ul class="navbar-nav">
<li class="nav-item form-inline">
<a class="ml-2 ml-lg-0 btn btn-sm btn-primary px-3" href="/account/join/">Join</a>
</li>
<li class="nav-item">
<a class="btn text-light" href="/account/login/?next=%2Fadvanced-visual-studio-code-python%2F">Sign&#8209;In</a>
</li>
</ul>
</div>
</div>
</nav>
<div class="container main-content">
<div class="row justify-content-center">
<div class="col-md-11 col-lg-8 article with-headerlinks">
<figure class="embed-responsive embed-responsive-16by9">
<img class="card-img-top m-0 p-0 embed-responsive-item rounded" style="object-fit: contain;" alt="Advanced Visual Studio Code for Python Developers" src="https://files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg" width="1920" height="1080" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg&amp;w=480&amp;sig=4481c46f0a734224a5bebdbd4ea0284b75819a7f 480w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg&amp;w=960&amp;sig=6e8f0ec5f7b2624beb26a5c224be5adc0e896288 960w, https://files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg 1920w" sizes="75vw">
</figure>
<h1>Advanced Visual Studio Code for Python Developers</h1>
<div class="mb-0">
<span class="text-muted">by <a class="text-muted" href="#author">Anthony Shaw</a>
<span class="ml-2 fa fa-clock-o"></span> Nov 10, 2021
<span class="ml-2 mr-1 fa fa-comments"></span><a class="text-muted" href="#reader-comments"><span class="disqus-comment-count" data-disqus-identifier="https://realpython.com/advanced-visual-studio-code-python/"></span></a>
<span class="ml-2 fa fa-tags" aria-hidden="true"></span>
<a href="/tutorials/advanced/" class="badge badge-light text-muted">advanced</a>
<a href="/tutorials/python/" class="badge badge-light text-muted">python</a>
<a href="/tutorials/tools/" class="badge badge-light text-muted">tools</a>
<div class="d-sm-flex flex-row justify-content-between my-3 text-center">
<div class="jsCompletionStatusWidget btn-group mb-0">
<button title="Click to mark as completed" class="jsBtnCompletion btn btn-secondary border-right " style="border-top-right-radius: 0; border-bottom-right-radius: 0;" disabled>Mark as Completed</button>
<button title="Add bookmark" class="jsBtnBookmark btn btn-secondary border-left" disabled><i class="fa fa-fw fa-bookmark-o"></i></button>
</div>
<div class="align-self-center my-2">
<span>
<a target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet/?text=Check out this %23Python tutorial: Advanced%20Visual%20Studio%20Code%20for%20Python%20Developers by @realpython&url=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-twitter text-light mb-1"><i class="mr-1 fa fa-twitter text-light"></i>Tweet</a>
<a target="_blank" rel="nofollow" href="https://facebook.com/sharer/sharer.php?u=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-facebook text-light mb-1"><i class="mr-1 fa fa-facebook text-light"></i>Share</a>
<a target="_blank" rel="nofollow" href="mailto:?subject=Python article for you&body=Check out this Python tutorial:%0A%0AAdvanced%20Visual%20Studio%20Code%20for%20Python%20Developers%0A%0Ahttps%3A//realpython.com/advanced-visual-studio-code-python/" class="badge badge-red text-light mb-1"><i class="mr-1 fa fa-envelope text-light"></i>Email</a>
</span>
</div>
</div>
</div>
<div class="article-body">
<div class="bg-light sidebar-module sidebar-module-inset" id="toc">
<p class="h3 mb-2 text-muted">Table of Contents</p>
<div class="toc">
<ul>
<li><a href="#mastering-the-visual-studio-code-user-interface">Mastering the Visual Studio Code User Interface</a><ul>
<li><a href="#keyboard-shortcuts">Keyboard Shortcuts</a></li>
<li><a href="#customizing-the-user-interface">Customizing the User Interface</a></li>
<li><a href="#setting-up-your-terminal">Setting Up Your Terminal</a></li>
<li><a href="#team-settings-vs-personal-settings">Team Settings vs Personal Settings</a></li>
</ul>
</li>
<li><a href="#linting-and-formatting">Linting and Formatting</a><ul>
<li><a href="#setting-up-pylance">Setting Up Pylance</a></li>
<li><a href="#setting-format-and-lint-on-save">Setting Format and Lint on Save</a></li>
</ul>
</li>
<li><a href="#testing-your-python-code-in-visual-studio-code">Testing Your Python Code in Visual Studio Code</a><ul>
<li><a href="#configuring-test-integration">Configuring Test Integration</a></li>
<li><a href="#executing-tests">Executing Tests</a></li>
</ul>
</li>
<li><a href="#using-the-visual-studio-code-tasks-system">Using the Visual Studio Code Tasks System</a><ul>
<li><a href="#using-tasks-to-compile-wheels">Using Tasks to Compile Wheels</a></li>
<li><a href="#using-tasks-for-django">Using Tasks for Django</a></li>
<li><a href="#chaining-tasks">Chaining Tasks</a></li>
<li><a href="#using-tasks-to-run-tox">Using Tasks to Run Tox</a></li>
<li><a href="#using-the-task-explorer-extension">Using the Task Explorer Extension</a></li>
</ul>
</li>
<li><a href="#debugging-your-python-scripts-in-visual-studio-code">Debugging Your Python Scripts in Visual Studio Code</a><ul>
<li><a href="#setting-watches">Setting Watches</a></li>
<li><a href="#configuring-a-launch-file">Configuring a Launch File</a></li>
</ul>
</li>
<li><a href="#mastering-remote-development">Mastering Remote Development</a><ul>
<li><a href="#remote-development-with-containers">Remote Development With Containers</a></li>
<li><a href="#remote-development-with-ssh">Remote Development With SSH</a></li>
<li><a href="#remote-development-with-wsl">Remote Development With WSL</a></li>
</ul>
</li>
<li><a href="#working-with-data-science-tools">Working With Data Science Tools</a><ul>
<li><a href="#installing-the-jupyter-notebook-extension">Installing the Jupyter Notebook Extension</a></li>
<li><a href="#getting-started-with-jupyter-notebooks-in-vs-code">Getting Started With Jupyter Notebooks in VS Code</a></li>
<li><a href="#using-the-data-viewer">Using the Data Viewer</a></li>
<li><a href="#using-the-rainbow-csv-extension">Using the Rainbow CSV Extension</a></li>
</ul>
</li>
<li><a href="#adding-bonus-extensions-to-visual-studio-code">Adding Bonus Extensions to Visual Studio Code</a><ul>
<li><a href="#code-spell-checker">Code Spell Checker</a></li>
<li><a href="#docker">Docker</a></li>
<li><a href="#thunder-client">Thunder Client</a></li>
<li><a href="#vs-code-pets">VS Code Pets</a></li>
</ul>
</li>
<li><a href="#conclusion">Conclusion</a></li>
</ul>
</div>
</div>
<div class="sidebar-module sidebar-module-inset p-0" style="overflow:hidden;">
<div style="display:block;position:relative;">
<div style="display:block;width:100%;padding-top:12.5%;"></div>
<div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div>
</div>
<a class="small text-muted" href="/account/join/" rel="nofollow"> <i class="fa fa-info-circle" aria-hidden="true"> </i> Remove ads</a>
</div>
<p>Visual Studio Code, or <strong>VS Code</strong> for short, is a free and open source code editor by Microsoft. You can use VS Code as a <strong>lightweight code editor</strong> to make quick changes, or you can configure it as an <a href="https://en.wikipedia.org/wiki/Integrated_development_environment">integrated development environment (IDE)</a> through the use of <strong>third-party extensions</strong>. In this tutorial, you&rsquo;re going to look at how to get the most out of VS Code for Python development.</p>
<p>During this tutorial, you&rsquo;ll learn how you can <strong>configure</strong>, <strong>extend</strong>, and <strong>optimize</strong> VS Code for a more effective and productive Python development environment. After finishing this tutorial, you&rsquo;ll have a variety of tools to help you be more productive using VS Code. It can be a powerful tool for rapid Python development.</p>
<p><strong>In this tutorial, you&rsquo;ll learn how to:</strong></p>
<ul>
<li>Customize your <strong>user interface</strong></li>
<li>Run and monitor <strong>Python tests</strong></li>
<li><strong>Lint</strong> and <strong>format</strong> your code automatically</li>
<li>Leverage <strong>type annotations</strong> and <strong>Pylance</strong> to write code faster with higher accuracy</li>
<li>Configure and utilize both <strong>local and remote debugging</strong></li>
<li>Set up <strong>data science tools</strong></li>
</ul>
<p>As usual, this tutorial is full of links, tips, and tricks to help you on your way.</p>
<p>If you haven&rsquo;t already installed <a href="https://code.visualstudio.com/download">Visual Studio Code</a> or the <a href="https://marketplace.visualstudio.com/items?itemName=ms-python.python">Python extension</a>, you&rsquo;ll need both for this tutorial. If you&rsquo;re just getting started with VS Code, you might want to check out Jon Fincher&rsquo;s tutorial on <a href="https://realpython.com/python-development-visual-studio-code/">Python development in Visual Studio Code</a> before continuing with this one.</p>
<div class="alert alert-warning" role="alert">
<p><strong markdown="1">Free Bonus:</strong> <a href="https://realpython.com/bonus/python-mastery-course/" class="alert-link" data-toggle="modal" data-target="#modal-python-mastery-course" data-focus="false" markdown="1">5 Thoughts On Python Mastery</a>, a free course for Python developers that shows you the roadmap and the mindset you&rsquo;ll need to take your Python skills to the next level.</p>
</div>
<section class="section2" id="mastering-the-visual-studio-code-user-interface"><h2>Mastering the Visual Studio Code User Interface<a class="headerlink" href="#mastering-the-visual-studio-code-user-interface" title="Permanent link"></a></h2>
<p>By default, VS Code&rsquo;s user interface is designed for everyone&mdash;whether you&rsquo;re writing C++, doing front-end development with JavaScript and CSS, or using data science tools like Jupyter Notebooks. In this first section, you&rsquo;ll explore how to tailor VS Code to support how you work.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div><section class="section3" id="keyboard-shortcuts"><h3>Keyboard Shortcuts<a class="headerlink" href="#keyboard-shortcuts" title="Permanent link"></a></h3>
<p>For almost everything that you do in VS Code, you can do it directly from the keyboard. You can map all activities in VS Code, whether they&rsquo;re built-in or provided via extensions, to a keyboard shortcut.</p>
<p>A small subset of built-in commands is already mapped in <a href="https://code.visualstudio.com/docs/getstarted/keybindings">Keyboard Shortcuts</a>. If you want to learn these default shortcuts, print out the PDF for <a href="https://code.visualstudio.com/shortcuts/keyboard-shortcuts-windows.pdf">Windows</a>, <a href="https://code.visualstudio.com/shortcuts/keyboard-shortcuts-macos.pdf">macOS</a>, or <a href="https://code.visualstudio.com/shortcuts/keyboard-shortcuts-linux.pdf">Linux</a> and pin it next to your monitor.</p>
<p>As a Python developer, a lot of the commands you&rsquo;ll use in Visual Studio Code are provided from extensions, similar to the Python extension that you already installed. These don&rsquo;t come with shortcuts mapped by default, but you can configure them using VS Code&rsquo;s <a href="https://code.visualstudio.com/docs/getstarted/keybindings#_keyboard-shortcuts-editor">Keyboard Shortcuts editor</a>.</p>
<section class="section4" id="using-the-keyboard-shortcuts-editor"><h4>Using the Keyboard Shortcuts Editor<a class="headerlink" href="#using-the-keyboard-shortcuts-editor" title="Permanent link"></a></h4>
<p>Open the Keyboard Shortcuts editor by going to <em>File → Preferences → Keyboard Shortcuts</em> or <em>Code → Preferences → Keyboard Shortcuts</em> on macOS:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-keyboard-shortcuts.687df9891a26.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-keyboard-shortcuts.687df9891a26.png" width="3130" height="1736" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-keyboard-shortcuts.687df9891a26.png&amp;w=782&amp;sig=a1e8417ec61a7de6eba529568d87f9f7fd1f17cf 782w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-keyboard-shortcuts.687df9891a26.png&amp;w=1565&amp;sig=185c3e856d39e59775327e58d7496dc1b09211aa 1565w, https://files.realpython.com/media/vscode-keyboard-shortcuts.687df9891a26.png 3130w" sizes="75vw" alt="VS Code Keyboard Shortcut Window" data-asset="3672" /></a></figure>
<p>In this editor, you can see a list of all the existing shortcuts along with their details:</p>
<ul>
<li><em>Command</em>: The command or action to be run</li>
<li><em>Keybinding</em>: The sequence of keys to press to trigger this command, with a blank indicating that there&rsquo;s no mapping</li>
<li><em>When</em>: Conditions that need to be met for this keybinding to work, with a minus sign (<code>-</code>) indicating that there are no requirements</li>
<li><em>Source</em>: Where this binding was configured, either defined by <em>Default</em>, <em>User</em>, or <em>Extension</em>, the last one indicating that you provided it by installing a keymap extension</li>
</ul>
<p>To override an existing binding, right-click on the existing action and click <em>Change Keybinding</em>. To assign a keybinding to a command that has no binding, double-click on it. If the key sequence you press is already assigned to something else, VS Code will warn you with a link to see which commands are mapped to this keybinding.</p>
<p>As an example, type <code>python create terminal</code> in the search box at the top. If no results come up, make sure you have the Python extension installed. Press <span class="keys"><kbd class="key-enter">Enter</kbd></span> to assign a keybinding, like <span class="keys"><kbd class="key-control">Ctrl</kbd><span>+</span><kbd class="key-alt">Alt</kbd><span>+</span><kbd class="key-t">T</kbd></span>, and then hit <span class="keys"><kbd class="key-enter">Enter</kbd></span> again.</p>
<p>To assign that shortcut to only work when you&rsquo;re editing Python code, right-click on the shortcut and select <em>Change When Expression</em>. Enter the expression <code>editorLangId == 'python'</code>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-screenshot-2.c1a3c78e75e1.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-screenshot-2.c1a3c78e75e1.png" width="2558" height="742" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-screenshot-2.c1a3c78e75e1.png&amp;w=639&amp;sig=802a6d799cab73696ebccf67a2df67a772d24e57 639w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-screenshot-2.c1a3c78e75e1.png&amp;w=1279&amp;sig=6826ae50bf45a8fddd5a8018d9af0c2dfa2ca872 1279w, https://files.realpython.com/media/vscode-screenshot-2.c1a3c78e75e1.png 2558w" sizes="75vw" alt="Assigned keyboard shortcut" data-asset="3673" /></a></figure>
<p>There are <a href="https://code.visualstudio.com/api/references/when-clause-contexts">more conditional operators</a> to choose from if you need something more specific. Here are some examples to get you started:</p>
<ul>
<li>Use <strong><code>resourceFilename == '__init__.py'</code></strong> when the file you&rsquo;re editing is <code>__init__.py</code></li>
<li>Use <strong><code>editorLangId == 'python'</code></strong> when working with Python. If needed, you can also replace <code>'python'</code> with another <a href="https://code.visualstudio.com/docs/languages/identifiers#_known-language-identifiers">language identifier</a>.</li>
<li>Use <strong><code>editorHasSelection</code></strong> for when you&rsquo;re inside the editor.</li>
</ul>
<p>Once you&rsquo;ve configured this extension, open up a Python file in the editor to try it out by pressing your newly assigned keyboard shortcut <span class="keys"><kbd class="key-control">Ctrl</kbd><span>+</span><kbd class="key-alt">Alt</kbd><span>+</span><kbd class="key-t">T</kbd></span> to open up a Python terminal.</p>
</section><section class="section4" id="setting-up-keyboard-shortcuts-for-commands-from-the-command-palette"><h4>Setting Up Keyboard Shortcuts for Commands From the Command Palette<a class="headerlink" href="#setting-up-keyboard-shortcuts-for-commands-from-the-command-palette" title="Permanent link"></a></h4>
<p>You&rsquo;ll refer to the <strong>Command Palette</strong> many times in this tutorial. Most of the functionality in VS Code is accessible through the UI from <a href="https://en.wikipedia.org/wiki/Context_menu">context menus</a>, but you won&rsquo;t find everything there. Anything that can be done in the core editor or via an extension is available in the Command Palette. You can get to the Command Palette by pressing one of these keyboard shortcuts:</p>
<ul>
<li><strong>macOS:</strong> <span class="keys"><kbd class="key-f1">F1</kbd></span> or <span class="keys"><kbd class="key-command">Cmd</kbd><span>+</span><kbd class="key-shift">Shift</kbd><span>+</span><kbd class="key-p">P</kbd></span></li>
<li><strong>Windows or Linux:</strong> <span class="keys"><kbd class="key-f1">F1</kbd></span> or <span class="keys"><kbd class="key-control">Ctrl</kbd><span>+</span><kbd class="key-shift">Shift</kbd><span>+</span><kbd class="key-p">P</kbd></span></li>
</ul>
<p>To run a command, type its descriptive name, like <code>Python: Run All Tests</code>. Once the Command Palette is up and the command you want is at the top of the menu, click the cog on the right to assign a keyboard shortcut:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-screenshot-3.e555858553f3.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-screenshot-3.e555858553f3.png" width="2262" height="662" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-screenshot-3.e555858553f3.png&amp;w=565&amp;sig=713ca34104cb4887902d85885d58fc43c244767f 565w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-screenshot-3.e555858553f3.png&amp;w=1131&amp;sig=f88a024194f1991f4fb2cd18ab29ee218c166f05 1131w, https://files.realpython.com/media/vscode-screenshot-3.e555858553f3.png 2262w" sizes="75vw" alt="Assigning a shortcut from the command palette" data-asset="3674" /></a></figure>
<p>Once you&rsquo;ve started using the Command Palette regularly, you may find that there are five to ten commands you run really often. Assign some shortcuts to those commands to save yourself a few extra keystrokes.</p>
</section><section class="section4" id="installing-keyboard-mappings-from-other-editors"><h4>Installing Keyboard Mappings From Other Editors<a class="headerlink" href="#installing-keyboard-mappings-from-other-editors" title="Permanent link"></a></h4>
<p>If you&rsquo;ve been working in another editor or IDE for some time, you may have your usual keyboard shortcuts committed to muscle memory.</p>
<p>You&rsquo;ll find helpful keyboard mappings in extensions for <a href="https://marketplace.visualstudio.com/items?itemName=vscodevim.vim">Vim</a>, <a href="https://marketplace.visualstudio.com/items?itemName=k--kato.intellij-idea-keybindings">IntelliJ and PyCharm</a>, <a href="https://marketplace.visualstudio.com/items?itemName=ms-vscode.sublime-keybindings">Sublime Text</a>, <a href="https://marketplace.visualstudio.com/items?itemName=ms-vscode.notepadplusplus-keybindings">Notepad++</a>, <a href="https://marketplace.visualstudio.com/items?itemName=lfs.vscode-emacs-friendly">Emacs</a>, and <a href="https://marketplace.visualstudio.com/items?itemName=ms-vscode.atom-keybindings">Atom</a>. </p>
<p>If your previous editor isn&rsquo;t on this list, you may find that someone else has created a mapping extension for you. <a href="https://marketplace.visualstudio.com/search?target=VSCode&amp;category=Keymaps&amp;sortBy=Relevance">Keymaps</a> is a helpful category on the <a href="https://marketplace.visualstudio.com">VS Code extension marketplace</a>.</p>
<p>Once you&rsquo;ve installed a keymap extension, you may also find additional options to customize it beyond the defaults. For example, you can use the Vim keymap extension to configure Vim features such as whether to start in insert mode.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section3" id="customizing-the-user-interface"><h3>Customizing the User Interface<a class="headerlink" href="#customizing-the-user-interface" title="Permanent link"></a></h3>
<p>The first things you should do when jumping into the driving seat of a car are to adjust the seat, adjust the rear-view mirror, and set the steering column to the right height. Code editors are no different. They come with a default layout that works okay for everyone but not especially well for anyone. You don&rsquo;t want to stretch to reach the pedals. Let&rsquo;s set up your VS Code environment to suit you and make it look great on the way.</p>
<p>First, the <strong>Activity Bar</strong> on the left-hand side of VS Code is the main navigation tool to switch between the <strong>Explorer</strong> view used to see your files, the <strong>Source Control</strong> view, the <strong>Search</strong> view, the <strong>Run and Debug</strong> view, and the <strong>Extensions</strong> view. You&rsquo;re not limited to these options. Many extensions come with views that are hidden by default. Right-click on the <em>Activity Bar</em> to control which views you see:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/activity_bar.2f756ee30790.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block w-75" src="https://files.realpython.com/media/activity_bar.2f756ee30790.png" width="1414" height="1482" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/activity_bar.2f756ee30790.png&amp;w=353&amp;sig=ed530aae1338b1630a7a76c169607ed8d3fd67fb 353w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/activity_bar.2f756ee30790.png&amp;w=707&amp;sig=71b53155baaf286ede8813d2e75b95c912494823 707w, https://files.realpython.com/media/activity_bar.2f756ee30790.png 1414w" sizes="75vw" alt="VS Code activity bar" data-asset="3729" /></a></figure>
<p>You can also use this menu to hide any views that you never use. Keep in mind that you&rsquo;re not limited to the views on the list. If there are some panels within a main view&mdash;for example, you can find some additional panels nested inside the <em>Explorer</em> view&mdash;you can drag them to the <em>Activity Bar</em> to create a permanent shortcut:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-add-activity-bar-item.66db2c945797.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block w-75" src="https://files.realpython.com/media/vscode-add-activity-bar-item.66db2c945797.png" width="928" height="730" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-add-activity-bar-item.66db2c945797.png&amp;w=232&amp;sig=0fbabd429c83f7c92fb160dfa3e9071935f0e52f 232w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-add-activity-bar-item.66db2c945797.png&amp;w=464&amp;sig=ed2babefaf722e75f93d1389d9a6b26470bdb272 464w, https://files.realpython.com/media/vscode-add-activity-bar-item.66db2c945797.png 928w" sizes="75vw" alt="Dragging an item to the activity bar" data-asset="3730" /></a></figure>
<p>Use this feature for views that you use all the time.</p>
<section class="section4" id="using-split-screens"><h4>Using Split Screens<a class="headerlink" href="#using-split-screens" title="Permanent link"></a></h4>
<p>Python&rsquo;s style guide, <a href="https://realpython.com/python-pep8/">PEP 8</a>, leans toward short line lengths. For wide screens, this leaves a lot of unused screen space.</p>
<p>When you find yourself needing to switch between two or more files, use the split panel functionality to show many editor regions at once. You can access this functionality through the Command Palette with the command <code>View: Split Editor</code>.</p>
<p>Alternatively, you can use the associated keyboard shortcut:</p>
<ul>
<li><strong>macOS:</strong> <span class="keys"><kbd class="key-command">Cmd</kbd><span>+</span><kbd class="key-backslash">\</kbd></span></li>
<li><strong>Windows or Linux:</strong> <span class="keys"><kbd class="key-control">Ctrl</kbd><span>+</span><kbd class="key-backslash">\</kbd></span></li>
</ul>
<p>You can also open the split editor functionality by going to <em>View → Editor Layout</em> or by right-clicking on a file&rsquo;s tab:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/split-pane.4192b6101cf3.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/split-pane.4192b6101cf3.png" width="1362" height="928" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/split-pane.4192b6101cf3.png&amp;w=340&amp;sig=7db6240538b0f691b1459ff7bc45851bd9136763 340w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/split-pane.4192b6101cf3.png&amp;w=681&amp;sig=8931bff3d767c7b5ec60ffac98a769f12728781c 681w, https://files.realpython.com/media/split-pane.4192b6101cf3.png 1362w" sizes="75vw" alt="VS Code splitting a panel" data-asset="3731" /></a></figure>
<p>This setup is really useful when writing unit tests with your test code on the left and the module you&rsquo;re testing on the right. </p>
<p>Some file types, like Markdown, have a preview region that you can use instead. Use the <code>Markdown: Open Preview to the Side</code> command to open the preview editor.</p>
</section><section class="section4" id="using-zen-mode-for-focused-work"><h4>Using Zen Mode for Focused Work<a class="headerlink" href="#using-zen-mode-for-focused-work" title="Permanent link"></a></h4>
<p>If you need your absolute focus on a single file or task in VS Code, then use Zen Mode by going to <em>View → Appearance → Zen Mode</em> to show a full-screen window with just the editor:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-zen-mode.39f6e34b9d84.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-zen-mode.39f6e34b9d84.png" width="5120" height="2880" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-zen-mode.39f6e34b9d84.png&amp;w=1280&amp;sig=8f206497c4647052d95c60d626a83a34ec259b41 1280w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-zen-mode.39f6e34b9d84.png&amp;w=2560&amp;sig=ced6e1ce41480f19e0a5e33216fe8762890a76bd 2560w, https://files.realpython.com/media/vscode-zen-mode.39f6e34b9d84.png 5120w" sizes="75vw" alt="VS Code in Zen Mode" data-asset="3732" /></a></figure>
<p>This feature is especially useful for blocking out noisy distractions and notifications so that you can just focus on getting your current task done.</p>
</section><section class="section4" id="theming"><h4>Theming<a class="headerlink" href="#theming" title="Permanent link"></a></h4>
<p>VS Code has a huge library of themes in the <a href="https://marketplace.visualstudio.com/search?target=VSCode&amp;category=Themes&amp;sortBy=Installs">VS Code Marketplace</a>. Some of the most popular themes out there are <a href="https://marketplace.visualstudio.com/items?itemName=equinusocio.vsc-material-theme">Material Theme</a>, <a href="https://marketplace.visualstudio.com/items?itemName=johnpapa.winteriscoming">Winter is Coming</a>, <a href="https://marketplace.visualstudio.com/items?itemName=dracula-theme.theme-dracula">Dracula</a>, <a href="https://marketplace.visualstudio.com/items?itemName=liviuschera.noctis">Noctis</a>, and <a href="https://marketplace.visualstudio.com/items?itemName=monokai.theme-monokai-pro-vscode">Monokai Pro</a>.</p>
<p>Let&rsquo;s focus on the <a href="https://marketplace.visualstudio.com/items?itemName=equinusocio.vsc-material-theme">Material Theme</a> as it comes with a broad set of color schemes to suit many tastes. You can install the extension from the <em>Extensions</em> view. Once installed, you can select a color theme by running <code>Preferences: Color Theme</code> in the Command Palette.</p>
<p>The Material Theme looks best with a custom icon theme. Icon themes are separate extensions from the color themes, so you have to install a second extension. Search for <code>pkief.material-icon-theme</code> in the <em>Extensions</em> view to find the most popular Material icon pack for the theme. After installing this, VS Code will prompt you to switch your icon pack.</p>
<p>This is the Material Theme with the Palenight color theme and the Material icon pack:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-material-palenight.969b3335bd77.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-material-palenight.969b3335bd77.png" width="3327" height="2089" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-material-palenight.969b3335bd77.png&amp;w=831&amp;sig=9604de200bc975fdb5e2754a82ed4a5172735514 831w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-material-palenight.969b3335bd77.png&amp;w=1663&amp;sig=f9d1840586645d70288e7bfb4ed5e0631a9f143e 1663w, https://files.realpython.com/media/vscode-material-palenight.969b3335bd77.png 3327w" sizes="75vw" alt="VS Code with the pale night color theme" data-asset="3734" /></a></figure>
<p>You can change the icon theme at any time from the Command Palette by using the command <code>Preferences: File Icon Theme</code> and then selecting one of the icon themes from the list.</p>
</section><section class="section4" id="installing-a-better-programming-font"><h4>Installing a Better Programming Font<a class="headerlink" href="#installing-a-better-programming-font" title="Permanent link"></a></h4>
<p>Programming fonts are a special group of typefaces, typically with fixed-width characters called <a href="https://en.wikipedia.org/wiki/Monospaced_font">monospace</a>. There&rsquo;s a long list of available fonts to browse at <a href="https://www.programmingfonts.org/">ProgrammingFonts.org</a>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/programming-fonts.25bace155d9f.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/programming-fonts.25bace155d9f.png" width="2362" height="1344" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/programming-fonts.25bace155d9f.png&amp;w=590&amp;sig=a9e41bf551036aab4f62c513e77158aa4298b8dd 590w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/programming-fonts.25bace155d9f.png&amp;w=1181&amp;sig=226c64f9d47a4c0f180a633964028a829ee3e1a3 1181w, https://files.realpython.com/media/programming-fonts.25bace155d9f.png 2362w" sizes="75vw" alt="Selecting a programming font" data-asset="3736" /></a></figure>
<p>Once you&rsquo;ve selected a font, go to <a href="https://www.nerdfonts.com/font-downloads">Nerd Fonts</a> to download it and install the font on your operating system. The downloads at Nerd Fonts are copies of the monospace fonts with support for glyphs, otherwise known as icons, which you can use inside the terminal prompt.</p>
<p>After installing your selected font, you need to change the <code>editor.fontFamily</code> setting to the name of the new font. You can do that by navigating to <em>Code → Preferences → Settings</em> and then selecting <em>Text Editor → Font</em> in the navigation dropdown. You can change the font your editor will use by adding the name of your new font in the first field of the <em>Font Family</em> setting.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section3" id="setting-up-your-terminal"><h3>Setting Up Your Terminal<a class="headerlink" href="#setting-up-your-terminal" title="Permanent link"></a></h3>
<p>You&rsquo;ll spend much of your Python development time inside a shell terminal. You can use a separate application, like iTerm2 or Windows Terminal, but VS Code already has a powerful built-in terminal window.</p>
<p>Because VS Code does need a bit of configuration to make it as powerful as a dedicated terminal application, you&rsquo;ll set that up now.</p>
<section class="section4" id="changing-the-default-shell-provider"><h4>Changing the Default Shell Provider<a class="headerlink" href="#changing-the-default-shell-provider" title="Permanent link"></a></h4>
<p>You can reconfigure the terminal window to have multiple profiles. These profiles form the dropdown list when you spawn a new terminal.</p>
<p>VS Code allows you to configure multiple terminal profiles. You can&rsquo;t edit terminal profiles in the settings UI, so you need to use the <code>Preferences: Open Settings (JSON)</code> command in the Command Palette to open the <code>settings.json</code> file. You&rsquo;ll notice that key-value pairs make up the settings file. Each key represents the configuration setting for VS Code or one of its extensions.</p>
<p>There are three terminal profile settings, which have the following names:</p>
<div class="table-responsive">
<table class="table table-hover">
<thead>
<tr>
<th>Operating System</th>
<th>Terminal Profile Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td><code>terminal.integrated.profiles.windows</code></td>
</tr>
<tr>
<td>Linux</td>
<td><code>terminal.integrated.profiles.linux</code></td>
</tr>
<tr>
<td>macOS</td>
<td><code>terminal.integrated.profiles.osx</code></td>
</tr>
</tbody>
</table>
</div>
<p>Once you type in the name, the editor autocompletes the default profiles into the JSON file. </p>
<p>Note that there&rsquo;s no Python REPL profile in the default settings. You can add a profile with the key <code>"python3-repl"</code> to the integrated profiles JSON file so that VS Code makes it available as a profile option and drops you straight onto the REPL prompt:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;python3-repl&quot;</span><span class="p">:</span> <span class="p">{</span>
    <span class="nt">&quot;path&quot;</span><span class="p">:</span> <span class="s2">&quot;python3&quot;</span><span class="p">,</span>
    <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;-q&quot;</span><span class="p">]</span>
<span class="p">}</span>
</code></pre></div>
<p>The <code>-q</code> flag is a Python command-line flag to stop the version header from showing. You can add any extra Python command-line flags to <code>"args"</code>.</p>
<p>Once configured, your profiles should look something like this, depending on your OS:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;terminal.integrated.profiles.osx&quot;</span><span class="p">:</span> <span class="p">{</span>
    <span class="nt">&quot;bash&quot;</span><span class="p">:</span> <span class="p">{</span>
        <span class="nt">&quot;path&quot;</span><span class="p">:</span> <span class="s2">&quot;bash&quot;</span><span class="p">,</span>
        <span class="nt">&quot;icon&quot;</span><span class="p">:</span> <span class="s2">&quot;terminal-bash&quot;</span><span class="p">,</span>
    <span class="p">},</span>
    <span class="nt">&quot;zsh&quot;</span><span class="p">:</span> <span class="p">{</span>
        <span class="nt">&quot;path&quot;</span><span class="p">:</span> <span class="s2">&quot;zsh&quot;</span>
    <span class="p">},</span>
    <span class="nt">&quot;pwsh&quot;</span><span class="p">:</span> <span class="p">{</span>
        <span class="nt">&quot;path&quot;</span><span class="p">:</span> <span class="s2">&quot;pwsh&quot;</span><span class="p">,</span>
        <span class="nt">&quot;icon&quot;</span><span class="p">:</span> <span class="s2">&quot;terminal-powershell&quot;</span><span class="p">,</span>
    <span class="p">},</span>
    <span class="nt">&quot;python3-repl&quot;</span><span class="p">:</span> <span class="p">{</span>
        <span class="nt">&quot;path&quot;</span><span class="p">:</span> <span class="s2">&quot;python3&quot;</span><span class="p">,</span>
        <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;-q&quot;</span><span class="p">]</span>
    <span class="p">}</span>
<span class="p">},</span>
</code></pre></div>
<p>VS Code has two launch modes for terminals: <strong>integrated</strong> and <strong>external</strong>. Once you&rsquo;ve configured the profiles, you can set the default profile for your integrated terminal by setting the value for <code>"terminal.integrated.defaultProfile.osx"</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;terminal.integrated.defaultProfile.osx&quot;</span><span class="p">:</span> <span class="s2">&quot;zsh&quot;</span><span class="p">,</span>
</code></pre></div>
<p>If something gets launched in an external terminal, it will use the default shell of your operating system. If you prefer a different terminal app, like <a href="https://www.iterm2.com">iTerm 2</a> for macOS or <a href="https://www.microsoft.com/en-us/p/windows-terminal/9n0dx20hk701">Windows Terminal</a> for Windows, you can change the default external terminal as well:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;terminal.external.osxExec&quot;</span><span class="p">:</span> <span class="s2">&quot;iTerm.app&quot;</span><span class="p">,</span>
</code></pre></div>
<p>With this setting for macOS, for example, you&rsquo;re saying that VS Code should bring up the iTerm app every time it launches an external terminal window.</p>
<p>There are even more settings you can change in regards to terminals in VS Code. For example, you can make VS Code activate your virtual environment automatically when you bring up a new terminal window, and you can customize the look and feel of your terminal by adding custom prompts. You&rsquo;ll explore how to do both in this tutorial.</p>
</section><section class="section4" id="virtual-environment-activation-in-the-terminal"><h4>Virtual Environment Activation in the Terminal<a class="headerlink" href="#virtual-environment-activation-in-the-terminal" title="Permanent link"></a></h4>
<p>Virtual environments are very important for managing multiple dependencies across Python projects. Visual Studio Code will activate any <a href="https://realpython.com/python-virtual-environments-a-primer/">Python virtual environment</a> once the interpreter is selected. If you already have a virtual environment, run <code>Python: Select Interpreter</code> from the Command Palette to select the Python interpreter virtual environment.</p>
<p>If you don&rsquo;t have one, then create one inside the terminal. VS Code can automatically pick it up if the virtual environment path is named <code>.venv/</code>, <code>env/</code>, or <code>venv/</code>.</p>
<p>After you set the interpreter, you&rsquo;ll automatically activate the virtual environment when you start a new terminal window inside VS Code:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-venv.4ae757c09cf3.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-venv.4ae757c09cf3.png" width="2988" height="738" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-venv.4ae757c09cf3.png&amp;w=747&amp;sig=96e1c667a2b409b9a89bf5700ca64b4b29abce60 747w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-venv.4ae757c09cf3.png&amp;w=1494&amp;sig=c743958a440d1bce0d2c9551a2dd63032f3534b7 1494w, https://files.realpython.com/media/vscode-venv.4ae757c09cf3.png 2988w" sizes="75vw" alt="VS Code with the venv activated" data-asset="3735" /></a></figure>
<p>If you already had a terminal open, you can destroy it by clicking the garbage can icon.</p>
<p>Any commands you run inside the terminal, such as <code>python -m pip install</code>, will be for the activated virtual environment.</p>
<p>In the above screenshot, you can see a custom command prompt that uses the Oh My Posh prompt toolkit. In the next section, you&rsquo;ll install and configure Oh My Posh. Oh My Posh is optional, especially if you already have a custom command prompt installed.</p>
</section><section class="section4" id="installing-oh-my-posh"><h4>Installing Oh My Posh<a class="headerlink" href="#installing-oh-my-posh" title="Permanent link"></a></h4>
<p><a href="https://ohmyposh.dev/">Oh My Posh</a> is one of many libraries for customizing the command prompt of your terminal. It works across Linux, macOS, and Windows. It also works with all shells like Bash, Zsh, Fish, and PowerShell. You can install Oh My Posh to spice up your terminal.</p>
<p>If you&rsquo;re on macOS and using Bash, run the following commands to install Oh My Posh:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>brew tap jandedobbeleer/oh-my-posh
<span class="gp">$ </span>brew install oh-my-posh
<span class="gp">$ </span>curl https://github.com/JanDeDobbeleer/oh-my-posh/raw/main/themes/tonybaloney.omp.json -sLo ~/.mytheme.omp.json
<span class="gp">$ </span><span class="nb">echo</span> <span class="s2">&quot;eval \&quot;\$(oh-my-posh --init --shell bash --config ~/.mytheme.omp.json)\&quot;&quot;</span> &gt;&gt; ~/.profile
<span class="gp">$ </span>. ~/.profile
</code></pre></div>
<p>If you&rsquo;re on macOS and using Zsh, run the following commands to install Oh My Posh:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>brew tap jandedobbeleer/oh-my-posh
<span class="gp">$ </span>brew install oh-my-posh
<span class="gp">$ </span>curl https://github.com/JanDeDobbeleer/oh-my-posh/raw/main/themes/tonybaloney.omp.json -sLo ~/.mytheme.omp.json
<span class="gp">$ </span><span class="nb">echo</span> <span class="s2">&quot;eval \&quot;\$(oh-my-posh --init --shell bash --config ~/.mytheme.omp.json)\&quot;&quot;</span> &gt;&gt; ~/.zprofile
<span class="gp">$ </span>. ~/.zprofile
</code></pre></div>
<p>If you&rsquo;re on Windows and using PowerShell, run the following commands to install Oh My Posh:</p>
<div class="highlight pscon"><pre><span></span><code><span class="gp">PS C:\&gt; </span><span class="nb">Install-Module</span> <span class="n">oh-my-posh</span> <span class="n">-Scope</span> <span class="n">CurrentUser</span>
<span class="gp">PS C:\&gt; </span><span class="nb">Add-Content</span> <span class="nv">$PROFILE</span> <span class="s2">&quot;</span><span class="se">`n</span><span class="s2">Set-PoshPrompt -Theme tonybaloney&quot;</span>
</code></pre></div>
<p>Finally, if you&rsquo;re on Linux and using Bash, run the following commands to install Oh My Posh:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>sudo wget https://github.com/JanDeDobbeleer/oh-my-posh/releases/latest/download/posh-linux-amd64 -O /usr/local/bin/oh-my-posh
<span class="gp">$ </span>sudo chmod +x /usr/local/bin/oh-my-posh
<span class="gp">$ </span>curl https://github.com/JanDeDobbeleer/oh-my-posh/raw/main/themes/tonybaloney.omp.json -sLo ~/.mytheme.omp.json
<span class="gp">$ </span><span class="nb">echo</span> <span class="s2">&quot;eval \&quot;\$(oh-my-posh --init --shell bash --config ~/.mytheme.omp.json)\&quot;&quot;</span> &gt;&gt; ~/.bashrc
<span class="gp">$ </span>. ~/.bashrc
</code></pre></div>
<p>When you open up a new terminal in VS Code, you&rsquo;ll get this prompt:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-ohmyposh-terminal.4484c2cdff6d.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-ohmyposh-terminal.4484c2cdff6d.png" width="2790" height="602" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ohmyposh-terminal.4484c2cdff6d.png&amp;w=697&amp;sig=b1d2a90d6b375fa54a2e4eab2e77a16755b7f4ce 697w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ohmyposh-terminal.4484c2cdff6d.png&amp;w=1395&amp;sig=eaec30031394a779f9a243daf4ef2103df552964 1395w, https://files.realpython.com/media/vscode-ohmyposh-terminal.4484c2cdff6d.png 2790w" sizes="75vw" alt="VS Code Terminal with ohmyposh" data-asset="3760" /></a></figure>
<p>The components on the terminal are the folder, Git branch, and Python version. Check out the <a href="https://ohmyposh.dev/docs/themes">list of themes</a> for some other options.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> If you&rsquo;re using a custom terminal prompt like <a href="https://ohmyposh.dev/">Oh My Posh</a> or <a href="https://ohmyz.sh">Oh My Zsh</a>, you have to select one of the installed <a href="https://www.nerdfonts.com/font-downloads">Nerd Fonts</a> for the glyphs to render correctly in VS Code.</p>
</div>
<p>By default, the terminal will use the same font face that you configured for the editor, <code>editor.fontFamily</code>. You can override this by defining a different font family for the <code>terminal.integrated.fontFamily</code> identifier. You&rsquo;ll also need to update any external terminal applications you use.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section3" id="team-settings-vs-personal-settings"><h3>Team Settings vs Personal Settings<a class="headerlink" href="#team-settings-vs-personal-settings" title="Permanent link"></a></h3>
<p>VS Code has two levels of settings:</p>
<ol>
<li><strong>User settings</strong>, which apply to all projects</li>
<li><strong>Workspace settings</strong>, which only apply to that workspace</li>
</ol>
<p>If a setting is declared in both, the workspace setting will override the user setting.</p>
<p>The workspace configuration for VS Code and all of its extensions live within a <code>.vscode/</code> directory in the workspace root.</p>
<p>It&rsquo;s a good idea to put your project-agnostic settings into your user settings and your project-specific settings into <code>.vscode/</code>. By separating your personal user settings from your project settings, you and any other developers working on the project can be more effective.</p>
<section class="section4" id="global-user-settings-for-python"><h4>Global User Settings for Python<a class="headerlink" href="#global-user-settings-for-python" title="Permanent link"></a></h4>
<p>By default, the Python extension for Visual Studio Code has a very basic configuration. Many features like linting, formatting, and security checks are disabled because you need to install third-party tools like Black, Pylint, and Bandit to use them.</p>
<p>You can install these tools and make them available to every virtual environment by using either <code>pipx</code> or <code>pip install --user</code>. <a href="https://pypi.org/project/pipx/"><code>pipx</code></a> is preferable over <code>pip install --user</code> because it&rsquo;ll create and maintain a virtual environment for that package, keeping your global site packages smaller and reducing the risk of packaging conflicts.</p>
<p>Once <a href="https://pypa.github.io/pipx/installation/">you&rsquo;ve installed <code>pipx</code></a>, you can install the common tools:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>pipx install pylint <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install black <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install poetry <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install pipenv <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install bandit <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install mypy <span class="o">&amp;&amp;</span> <span class="se">\</span>
  pipx install flake8
</code></pre></div>
<p>Alternatively, use <code>python3 -m pip install --user</code> to install the common tools:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>python3 -m pip install --user pylint black poetry pipenv bandit mypy flake8
</code></pre></div>
<p>Once you&rsquo;ve installed the base tools, open the user settings from the Command Palette with <code>Preferences: Open Settings (JSON)</code>. Add settings for the preferences you want to apply to all projects:</p>
<div class="highlight json"><pre><span></span><code><span class="linenos"> 1</span><span class="nt">&quot;python.pipenvPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/pipenv&quot;</span><span class="p">,</span>
<span class="linenos"> 2</span><span class="nt">&quot;python.poetryPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/poetry&quot;</span><span class="p">,</span>
<span class="linenos"> 3</span><span class="nt">&quot;python.condaPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/conda&quot;</span><span class="p">,</span>
<span class="linenos"> 4</span><span class="nt">&quot;python.linting.enabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="linenos"> 5</span><span class="nt">&quot;python.linting.banditPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/bandit&quot;</span><span class="p">,</span>
<span class="linenos"> 6</span><span class="nt">&quot;python.linting.banditEnabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="linenos"> 7</span><span class="nt">&quot;python.linting.pylintPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/pylint&quot;</span><span class="p">,</span>
<span class="linenos"> 8</span><span class="nt">&quot;python.linting.mypyPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/mypy&quot;</span><span class="p">,</span>
<span class="linenos"> 9</span><span class="nt">&quot;python.linting.flake8Path&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/flake8&quot;</span><span class="p">,</span>
<span class="linenos">10</span><span class="nt">&quot;python.formatting.blackPath&quot;</span><span class="p">:</span> <span class="s2">&quot;${env:HOME}/.local/bin/black&quot;</span><span class="p">,</span>
</code></pre></div>
<p>With these settings, you&rsquo;ve managed to accomplish a couple of things that&rsquo;ll be useful for your development workflow across many projects:</p>
<ol>
<li><strong>Lines 1 to 3</strong> enable package discovery for projects enabled with <code>pipenv</code>, <code>poetry</code>, and <code>conda</code>.</li>
<li><strong>Line 4</strong> enables Python linting.</li>
<li><strong>Lines 5 to 6</strong> enable and set the path to <code>bandit</code>.</li>
<li><strong>Lines 7 to 10</strong> enable Python formatting and set the path to a globally-installed instance of <code>pylint</code>, <code>mypy</code>, <code>flake8</code>, and <code>black</code>.</li>
</ol>
<p>In each absolute path, you can automatically substitute your home folder by using the macro <code>${env:HOME}</code>.</p>
</section><section class="section4" id="workspace-settings"><h4>Workspace Settings<a class="headerlink" href="#workspace-settings" title="Permanent link"></a></h4>
<p>Outside of the user settings, you can use the <code>.vscode/</code> directory inside the workspace to configure some project-specific settings:</p>
<ul>
<li>Which <strong>commands</strong> to run to execute the project</li>
<li>How to <strong>test</strong> and <strong>debug</strong> the project</li>
<li>Which <strong>linter</strong> and <strong>formatter</strong> to use and any project-specific parameters</li>
</ul>
<p>The following files hold the VS Code preferences:</p>
<div class="table-responsive">
<table class="table table-hover">
<thead>
<tr>
<th>File</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>settings.json</code></td>
<td>VS Code settings</td>
</tr>
<tr>
<td><code>launch.json</code></td>
<td>Profiles to execute your project from the <em>Run and Debug</em> menu</td>
</tr>
<tr>
<td><code>tasks.json</code></td>
<td>Any additional tasks to execute, such as build steps</td>
</tr>
</tbody>
</table>
</div>
<p>Most of VS Code&rsquo;s settings, as well as the settings for your extensions, are in these three files.</p>
<p>In the workspace preferences, the following predefined variables are supported:</p>
<div class="table-responsive">
<table class="table table-hover">
<thead>
<tr>
<th>Predefined Variable</th>
<th>Meaning</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><code>${env.VARIABLE}</code></td>
<td>Any environment variable</td>
<td></td>
</tr>
<tr>
<td><code>${workspaceFolder}</code></td>
<td>The path of the folder opened in VS Code</td>
<td></td>
</tr>
<tr>
<td><code>${workspaceFolderBasename}</code></td>
<td>The name of the folder opened in VS Code without any slashes (<code>/</code>)</td>
<td></td>
</tr>
<tr>
<td><code>${file}</code></td>
<td>The currently opened file</td>
<td></td>
</tr>
<tr>
<td><code>${fileWorkspaceFolder}</code></td>
<td>The currently opened file&rsquo;s workspace folder</td>
<td></td>
</tr>
<tr>
<td><code>${relativeFile}</code></td>
<td>The currently opened file relative to <code>workspaceFolder</code></td>
<td></td>
</tr>
<tr>
<td><code>${cwd}</code></td>
<td>The task runner&rsquo;s current working directory on startup</td>
<td></td>
</tr>
<tr>
<td><code>${execPath}</code></td>
<td>The path to the running VS Code executable</td>
<td></td>
</tr>
<tr>
<td><code>${pathSeparator}</code></td>
<td>The character used by the operating system to separate components in file paths, for example, forward slash (<code>/</code>) or backslash (<code>\</code>)</td>
<td></td>
</tr>
</tbody>
</table>
</div>
<p>Using these variables will keep the project settings agnostic to the environment, so you can commit them into Git.</p>
<p>As an example of working with these settings, if you want to use Black as the default code formatter for this project, you can create the file <code>.vscode/settings.json</code> with this configuration:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
    <span class="nt">&quot;python.formatting.provider&quot;</span><span class="p">:</span> <span class="s2">&quot;black&quot;</span><span class="p">,</span>
<span class="p">}</span>
</code></pre></div>
<p>Anyone who checks out this project will now automatically use Black as the formatter for Python files. You&rsquo;ll see how this setting influences the autoformatting options in the section about <a href="#setting-format-and-lint-on-save">setting format and lint on save</a>.</p>
</section><section class="section4" id="using-the-settings-sync-extension"><h4>Using the Settings Sync Extension<a class="headerlink" href="#using-the-settings-sync-extension" title="Permanent link"></a></h4>
<p>If you use VS Code across multiple computers, you can enable the automatic synchronization of <a href="https://code.visualstudio.com/docs/editor/settings-sync">Settings, Keyboard Shortcuts, User Snippets, Extensions, and UI State</a>. If you haven&rsquo;t used <strong>Settings Sync</strong> before, you&rsquo;ll need to enable it:</p>
<ol>
<li>Run <code>Settings Sync: Turn On</code> in your Command Palette.</li>
<li>Follow the setup steps as prompted by VS Code. You can authenticate with GitHub.</li>
<li>Once the setup is done, run <code>Settings Sync: Configure</code> from the Command Palette.</li>
<li>Select what you want to sync.</li>
</ol>
<p>Once Settings Sync is configured on all the computers you have VS Code installed on, you can see the state for each synced setting by running <code>Settings Sync: Show Synced Data</code> from the Command Palette, where they&rsquo;ll show up under <em>Synced Machines</em>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/settings-sync.2650a0246a78.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/settings-sync.2650a0246a78.png" width="1074" height="548" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/settings-sync.2650a0246a78.png&amp;w=268&amp;sig=04dc0e6228ef94611ef09a653dae235c701b623c 268w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/settings-sync.2650a0246a78.png&amp;w=537&amp;sig=970b29d205e18dd6eb8ae7050d0631387c389692 537w, https://files.realpython.com/media/settings-sync.2650a0246a78.png 1074w" sizes="75vw" alt="VS Code Settings Sync Data" data-asset="3787" /></a></figure>
<p>This view shows you the last synced time for each of the settings and which machines are in sync.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section></section><section class="section2" id="linting-and-formatting"><h2>Linting and Formatting<a class="headerlink" href="#linting-and-formatting" title="Permanent link"></a></h2>
<p>All languages in Visual Studio Code can be formatted using one of the automated formatters, and the Python extension also supports linters. Linters and formatters perform different tasks:</p>
<ul>
<li>A <strong>formatter</strong> will change how your code looks but not how it works.</li>
<li>A <strong>linter</strong> will warn you about your code&rsquo;s compliance to standards on style, type adherence, security, and a range of best practices.</li>
</ul>
<p>The Python extension supports many third-party linters, and they often perform different jobs. For example, <strong>Bandit</strong> is a linter for security bugs and <strong>Flake8</strong> is a linter for style guide compliance.</p>
<p>The Python extension also comes with <strong>language server tooling</strong>, which performs analysis by loading the interfaces&mdash;methods, functions, classes&mdash;from your code and the libraries you use.</p>
<p>At the time of writing this tutorial, the latest and greatest language server extension for Python on Visual Studio Code is <a href="https://devblogs.microsoft.com/python/announcing-pylance-fast-feature-rich-language-support-for-python-in-visual-studio-code/">Pylance</a>.</p>
<section class="section3" id="setting-up-pylance"><h3>Setting Up Pylance<a class="headerlink" href="#setting-up-pylance" title="Permanent link"></a></h3>
<p>Pylance is an extension that works alongside Python in Visual Studio Code to provide deeper language support and introspection of Python code. Pylance will provide auto-completions, automated module imports, better code navigation, type checking, and <a href="https://github.com/microsoft/pylance-release">tons more</a>.</p>
<p>To get Pylance, go to the <em>Extensions</em> menu on the side bar and search <code>Pylance</code> (<code>ms-python.vscode-pylance</code>).</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> Pylance is now bundled with the Python extension, so you might already have it installed.</p>
</div>
<p>Once you have Pylance installed, there are two default configuration settings you may want to change in your <strong>user settings</strong> to get the most out of the extension.</p>
<p>The first setting to change is the type checking mode, which you can use to specify the level of type checking analysis performed:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;python.analysis.typeCheckingMode&quot;</span><span class="p">:</span> <span class="s2">&quot;basic&quot;</span>
</code></pre></div>
<p>By default, the type checking mode is set to <code>"off"</code>. </p>
<p>The other options are <code>"basic"</code> or <code>"strict"</code>. With <code>"basic"</code>, rules unrelated to type checking and rules for basic type checking are run. If the mode is set to <code>"strict"</code>, it will run all type checking rules at the highest severity of error. Set this to <code>"basic"</code> for a balance between strict and disabled.</p>
<p>The other default setting is <code>python.analysis.diagnosticMode</code>. By default, Pylance will inspect currently open files only. Changing this setting to <code>workspace</code> will inspect all Python files in the workspace, giving you a list of errors and warnings inside the <em>Explorer</em> view:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-all-inspections.015376128c17.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-all-inspections.015376128c17.png" width="912" height="362" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-all-inspections.015376128c17.png&amp;w=228&amp;sig=1707ebf8b05fcdf06fc7a1f16d32d18565b49bd2 228w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-all-inspections.015376128c17.png&amp;w=456&amp;sig=19048f5eef202f2d58e3ce104ce1f9d14c242ec0 456w, https://files.realpython.com/media/vscode-all-inspections.015376128c17.png 912w" sizes="75vw" alt="VS Code Workspace inspections" data-asset="3788" /></a></figure>
<p>You should only set <code>python.analysis.diagnosticMode</code> to <code>"workspace"</code> if you have some RAM to spare as it will consume more resources.</p>
<p>Pylance is most effective when it has information about <a href="https://realpython.com/python-type-checking/">the types used as the arguments to methods and functions</a> as well as the return types.</p>
<p>For external libraries, Pylance will use <a href="https://github.com/python/typeshed">typeshed</a> to infer the return types and argument types. Pylance also comes with type stubs and intelligence for some of the most popular data-science libraries, like pandas, Matplotlib, scikit-learn, and NumPy. If you&rsquo;re working with pandas, Pylance will give you information and examples for common functions and patterns:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/pylance-pandas.95fd6f68eb67.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/pylance-pandas.95fd6f68eb67.png" width="1484" height="680" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/pylance-pandas.95fd6f68eb67.png&amp;w=371&amp;sig=34057f228d6361ed303fbd519bdfecad514291e5 371w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/pylance-pandas.95fd6f68eb67.png&amp;w=742&amp;sig=3fb7e0eaa9924437891fb038ef4c7d3cb58da6f5 742w, https://files.realpython.com/media/pylance-pandas.95fd6f68eb67.png 1484w" sizes="75vw" alt="Pylance with Pandas" data-asset="3789" /></a></figure>
<p>For libraries that don&rsquo;t have type stubs on typeshed, Pylance will do its best to guess what the types are. Otherwise, you can <a href="https://realpython.com/python-type-checking/#adding-stubs">add your own type stubs</a>.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section><section class="section3" id="setting-format-and-lint-on-save"><h3>Setting Format and Lint on Save<a class="headerlink" href="#setting-format-and-lint-on-save" title="Permanent link"></a></h3>
<p><strong>Format Document</strong> is an action that applies formatting to any document in VS Code. For the Python extension, this action executes <code>"python.formatting.provider"</code>, which can be set to any of the supported auto-formatters: <code>"autopep8"</code>, <code>"black"</code>, or <code>"yapf"</code>.</p>
<p>Once you have configured the formatter in <code>settings.json</code>, you can set the formatter to run automatically whenever a file is saved. In the VS Code config, you can configure editor settings to only apply to certain file types by putting them in a <code>"[&lt;file_type&gt;]"</code> group:</p>
<div class="highlight json"><pre><span></span><code><span class="err">...</span>
<span class="nt">&quot;[python]&quot;</span><span class="p">:</span> <span class="p">{</span>
    <span class="nt">&quot;editor.formatOnSave&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="p">},</span>
</code></pre></div>
<p>Along with the execution of the formatter, you can also have the import statements organized both alphabetically and by splitting standard library modules, external modules, and package imports into groups with the following configuration:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;[python]&quot;</span><span class="p">:</span> <span class="p">{</span>
    <span class="err">...</span>
    <span class="nt">&quot;editor.codeActionsOnSave&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;source.organizeImports&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">},</span>
<span class="p">},</span>
</code></pre></div>
<p>Unlike formatting, linting is specific to the Python extension. To enable linting, choose a linter by running <code>Python: Select Linter</code> on the Command Palette. You can also enable one or more linters in your settings. For example, to enable the Bandit and Pylint linters, edit your <code>settings.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="err">...</span>
<span class="nt">&quot;python.linting.enabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="nt">&quot;python.linting.banditEnabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="nt">&quot;python.linting.pylintEnabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
</code></pre></div>
<p>To run the enabled linters whenever a file is saved, add the following setting to <code>settings.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="err">...</span>
<span class="nt">&quot;python.linting.lintOnSave&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
</code></pre></div>
<p>You might find it helpful to have more than one linter enabled. Keep in mind that Pylance already provides many of the insights you would get from pylint, so you likely don&rsquo;t need to enable both pylint <em>and</em> Pylance. In contrast, Flake8 provides stylistic feedback that Pylance doesn&rsquo;t cover, so you can use those two together.</p>
</section></section><section class="section2" id="testing-your-python-code-in-visual-studio-code"><h2>Testing Your Python Code in Visual Studio Code<a class="headerlink" href="#testing-your-python-code-in-visual-studio-code" title="Permanent link"></a></h2>
<p>Python offers plenty of <a href="https://realpython.com/python-testing/">tools to test your code</a>. The Python extension for VS Code supports the most popular test frameworks, <code>unittest</code> and <code>pytest</code>.</p>
<section class="section3" id="configuring-test-integration"><h3>Configuring Test Integration<a class="headerlink" href="#configuring-test-integration" title="Permanent link"></a></h3>
<p>To enable testing support for Python, run the <code>Python: Configure Tests</code> command from the Command Palette. VS Code will prompt you to select from one of the supported test frameworks and to specify which folder contains your tests.</p>
<p>This wizard adds the configuration options to <code>.vscode/settings.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="nt">&quot;python.testing.pytestEnabled&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="nt">&quot;python.testing.pytestArgs&quot;</span><span class="p">:</span> <span class="p">[</span>
    <span class="s2">&quot;tests&quot;</span>
<span class="p">],</span>
</code></pre></div>
<p>You can edit <code>python.testing.&lt;framework&gt;Args</code> with your preferred test framework to add any additional command-line flags. The example above shows configuration options for pytest.</p>
<p>If you have more complex settings for pytest, put those in <code>pytest.ini</code> instead of the VS Code settings. That way, you&rsquo;ll keep the configuration consistent with any automated testing or <a href="https://realpython.com/python-continuous-integration/">CI/CD</a> tooling.</p>
</section><section class="section3" id="executing-tests"><h3>Executing Tests<a class="headerlink" href="#executing-tests" title="Permanent link"></a></h3>
<p>Once you&rsquo;ve configured the test framework and arguments for the test runner, you can execute your tests by running the <code>Python: Run All Tests</code> command from the Command Palette. This will start the test runner with the configured arguments and put the test output into the <em>Python Test Log</em> output panel:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-test-run.5101c9d2422c.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-test-run.5101c9d2422c.png" width="1808" height="976" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-run.5101c9d2422c.png&amp;w=452&amp;sig=41d5ffe045eb51731d1a24a502bdba5c02a70449 452w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-run.5101c9d2422c.png&amp;w=904&amp;sig=c0ee684deb8e229ccf6ff9d66d03493700af2af7 904w, https://files.realpython.com/media/vscode-test-run.5101c9d2422c.png 1808w" sizes="75vw" alt="VS Code executing tests" data-asset="3790" /></a></figure>
<p>Once test discovery has completed, each test case will have an inline option to execute or debug that case:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-run-test-inline.582dca2206d6.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-run-test-inline.582dca2206d6.png" width="1192" height="292" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-run-test-inline.582dca2206d6.png&amp;w=298&amp;sig=6388dcedb8a291f64b0935916e38b5c3ce3f81b0 298w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-run-test-inline.582dca2206d6.png&amp;w=596&amp;sig=829c8b7e5d9dd75664ffd324da7aec128a234f6d 596w, https://files.realpython.com/media/vscode-run-test-inline.582dca2206d6.png 1192w" sizes="75vw" alt="VS Code run test inline" data-asset="3791" /></a></figure>
<p>Failed tests will be marked as having an error. You can see the failure from the test runner in both the <em>Python Test Log</em> panel and by hovering over the failed test case in your code:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-test-failure.8af6f6d0b222.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-test-failure.8af6f6d0b222.png" width="1584" height="522" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-failure.8af6f6d0b222.png&amp;w=396&amp;sig=2e7240827e2928ebb78a3dc5049138a0f37f9836 396w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-failure.8af6f6d0b222.png&amp;w=792&amp;sig=6d6ef77d76f4ad89d17b974f491691a09c0613d3 792w, https://files.realpython.com/media/vscode-test-failure.8af6f6d0b222.png 1584w" sizes="75vw" alt="VS Code test failure" data-asset="3792" /></a></figure>
<p>If you&rsquo;re running tests often, you can improve your testing experience in VS Code with the <strong>testing explorer</strong>.</p>
<p>To enable the testing panel, right-click the side bar and make sure that <em>Testing</em> is checked. The testing panel shows all the tests that the Python extension discovered and provides you with many features:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-test-explorer.0cef40886e92.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-test-explorer.0cef40886e92.png" width="800" height="510" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-explorer.0cef40886e92.png&amp;w=200&amp;sig=07246195cf1107d8512c783122874149411e6d9d 200w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-test-explorer.0cef40886e92.png&amp;w=400&amp;sig=dcc7f8cfe694a0ce2fee8228c0482ae0bc6dc757 400w, https://files.realpython.com/media/vscode-test-explorer.0cef40886e92.png 800w" sizes="75vw" alt="VS Code Test Explorer UI" data-asset="3793" /></a></figure>
<p>You have a visual representation of the test suite grouping and which tests failed. You also have menu buttons that let you run and debug tests.</p>
<p>VS Code&rsquo;s test system is powerful, but a lot of the functionality is disabled by default to keep it a lightweight editor. Beyond testing, there are other tasks you might want to run regularly from inside VS Code. This is where the tasks system comes in.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section2" id="using-the-visual-studio-code-tasks-system"><h2>Using the Visual Studio Code Tasks System<a class="headerlink" href="#using-the-visual-studio-code-tasks-system" title="Permanent link"></a></h2>
<p>Visual Studio Code supports compiled languages like Go, Rust, and C++, as well as interpreted languages like Python and Ruby. VS Code has a flexible system for executing configured <a href="https://code.visualstudio.com/docs/editor/tasks">tasks</a> that the user defines, like building and compiling the code.</p>
<p>Python code doesn&rsquo;t normally need to be compiled ahead of time because the Python interpreter <a href="https://realpython.com/cpython-source-code-guide/#part-3-the-cpython-compiler-and-execution-loop">does this for you</a>. Instead, you can use the <strong>tasks system</strong> to have pre-configured tasks that you would otherwise run at the command line, such as:</p>
<ul>
<li>Building a wheel or source distribution</li>
<li>Running tasks in frameworks like Django</li>
<li>Compiling Python C extensions</li>
</ul>
<p>VS Code tasks are commands or executables that you can run on demand using the Command Palette. There are two built-in default tasks:</p>
<ol>
<li>The <strong>build task</strong></li>
<li>The <strong>test task</strong></li>
</ol>
<p>Note that you can use tasks for anything that you might otherwise execute over the command line. You&rsquo;re not restricted to build and test activities.</p>
<section class="section3" id="using-tasks-to-compile-wheels"><h3>Using Tasks to Compile Wheels<a class="headerlink" href="#using-tasks-to-compile-wheels" title="Permanent link"></a></h3>
<p>If you have a <code>setup.py</code> file to <a href="https://realpython.com/pypi-publish-python-package/#building-your-package">build a package</a> for distribution on PyPI, you can use the tasks system to automate building the source (Python) and binary (compiled Python) distribution packages.</p>
<p>Tasks are defined in a <code>.vscode/tasks.json</code> file. To try it out, create <code>.vscode/tasks.json</code> and copy this configuration:</p>
<div class="highlight json"><pre><span></span><code><span class="linenos"> 1</span><span class="p">{</span>
<span class="linenos"> 2</span>  <span class="nt">&quot;version&quot;</span><span class="p">:</span> <span class="s2">&quot;2.0.0&quot;</span><span class="p">,</span>
<span class="linenos"> 3</span>  <span class="nt">&quot;tasks&quot;</span><span class="p">:</span> <span class="p">[</span>
<span class="linenos"> 4</span>    <span class="p">{</span>
<span class="linenos"> 5</span>      <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;shell&quot;</span><span class="p">,</span>
<span class="linenos"> 6</span>      <span class="nt">&quot;command&quot;</span><span class="p">:</span> <span class="s2">&quot;${command:python.interpreterPath}&quot;</span><span class="p">,</span>
<span class="linenos"> 7</span>      <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;setup.py&quot;</span><span class="p">,</span> <span class="s2">&quot;bdist_wheel&quot;</span><span class="p">,</span> <span class="s2">&quot;sdist&quot;</span><span class="p">],</span>
<span class="linenos"> 8</span>      <span class="nt">&quot;isBackground&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
<span class="linenos"> 9</span>      <span class="nt">&quot;options&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">},</span>
<span class="linenos">10</span>      <span class="nt">&quot;label&quot;</span><span class="p">:</span> <span class="s2">&quot;Build Wheel&quot;</span><span class="p">,</span>
<span class="linenos">11</span>      <span class="nt">&quot;group&quot;</span><span class="p">:</span> <span class="p">{</span>
<span class="linenos">12</span>        <span class="nt">&quot;kind&quot;</span><span class="p">:</span> <span class="s2">&quot;build&quot;</span><span class="p">,</span>
<span class="linenos">13</span>        <span class="nt">&quot;isDefault&quot;</span><span class="p">:</span> <span class="kc">true</span>
<span class="linenos">14</span>      <span class="p">}</span>
<span class="linenos">15</span>    <span class="p">}</span>
<span class="linenos">16</span>  <span class="p">]</span>
<span class="linenos">17</span><span class="p">}</span>
</code></pre></div>
<p>There are a few things to note in this example, so you&rsquo;ll look at the most important configurations line by line:</p>
<ul>
<li><strong>Line 5:</strong> The task type is <code>shell</code>, which specifies that this should run under your configured shell.</li>
<li><strong>Line 6:</strong> The command is <code>${command:python.interpreterPath}</code>, which is a built-in variable of the Python interpreter for this environment. That includes any activated virtual environment.</li>
<li><strong>Line 9:</strong> The option <code>"options": {"cwd": "${workspaceFolder}"}</code> specifies that this should run at the root of the project. You can change this to a subfolder if you need to.</li>
<li><strong>Lines 11 to 13:</strong> The <code>"group"</code> is set as <code>"build"</code>, and this task will be your default task because you set <code>"isDefault"</code> to <code>true</code>. This means that this task will run as the default build task.</li>
</ul>
<p>To execute the default build task, you can run <code>Tasks: Run Build Task</code> from the Command Palette or use the built-in keyboard shortcut, <span class="keys"><kbd class="key-command">Cmd</kbd><span>+</span><kbd class="key-f9">F9</kbd></span> or <span class="keys"><kbd class="key-control">Ctrl</kbd><span>+</span><kbd class="key-f9">F9</kbd></span>. Under the <em>Terminal</em> tab, you can find the output of the build command called whatever you specified in <code>"label"</code>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-build-output.91da66e5dd0a.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-build-output.91da66e5dd0a.png" width="1840" height="564" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-build-output.91da66e5dd0a.png&amp;w=460&amp;sig=25c3a1e30405b9d3907b6178dae847994aa4567c 460w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-build-output.91da66e5dd0a.png&amp;w=920&amp;sig=1e12d1d1be906abb451e2310dbd178f9cb382c6a 920w, https://files.realpython.com/media/vscode-build-output.91da66e5dd0a.png 1840w" sizes="75vw" alt="VS Code Build Output" data-asset="3794" /></a></figure>
<p>You&rsquo;re not limited to build scripts. The task system is a great solution to Django and Flask&rsquo;s management commands.</p>
</section><section class="section3" id="using-tasks-for-django"><h3>Using Tasks for Django<a class="headerlink" href="#using-tasks-for-django" title="Permanent link"></a></h3>
<p>Are you working with a Django application, and do you want to automate running <code>manage.py</code> from the command line? You can create a task using the <code>shell</code> type. That way, you can execute <code>manage.py</code> with the Django sub-command you wish to run, along with any arguments:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
  <span class="nt">&quot;version&quot;</span><span class="p">:</span> <span class="s2">&quot;2.0.0&quot;</span><span class="p">,</span>
  <span class="nt">&quot;tasks&quot;</span><span class="p">:</span> <span class="p">[</span>
    <span class="p">{</span>
      <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;shell&quot;</span><span class="p">,</span>
      <span class="nt">&quot;command&quot;</span><span class="p">:</span> <span class="s2">&quot;${command:python.interpreterPath}&quot;</span><span class="p">,</span>
      <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;manage.py&quot;</span><span class="p">,</span> <span class="s2">&quot;makemigrations&quot;</span><span class="p">],</span>
      <span class="nt">&quot;isBackground&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
      <span class="nt">&quot;options&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">},</span>
      <span class="nt">&quot;label&quot;</span><span class="p">:</span> <span class="s2">&quot;Make Migrations&quot;</span>
    <span class="p">}</span>
  <span class="p">]</span>
<span class="p">}</span>
</code></pre></div>
<p>To run this task, use the <code>Tasks: Run Task</code> command in the Command Palette and choose the <em>Make Migrations</em> task from the list.</p>
<p>You can copy this snippet and paste it for any Django commands you run on a regular basis, like <code>collectstatic</code>.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section><section class="section3" id="chaining-tasks"><h3>Chaining Tasks<a class="headerlink" href="#chaining-tasks" title="Permanent link"></a></h3>
<p>If you have multiple tasks that should run in sequence or a task that depends on another task, you can configure task dependencies in <code>tasks.json</code>.</p>
<p>Expanding on <a href="#using-tasks-to-compile-wheels">the <code>setup.py</code> example</a>, if you want to first build a source distribution of your package, you can add the following task to <code>tasks.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="err">...</span>
<span class="p">{</span>
  <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;shell&quot;</span><span class="p">,</span>
  <span class="nt">&quot;command&quot;</span><span class="p">:</span> <span class="s2">&quot;${command:python.interpreterPath}&quot;</span><span class="p">,</span>
  <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;setup.py&quot;</span><span class="p">,</span> <span class="s2">&quot;sdist&quot;</span><span class="p">],</span>
  <span class="nt">&quot;isBackground&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
  <span class="nt">&quot;options&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">},</span>
  <span class="nt">&quot;label&quot;</span><span class="p">:</span> <span class="s2">&quot;Build Source&quot;</span><span class="p">,</span>
<span class="p">}</span>
</code></pre></div>
<p>Within the default build task, you can then add a property <code>dependsOn</code> along with a list of the task labels that need to run first:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
  <span class="nt">&quot;version&quot;</span><span class="p">:</span> <span class="s2">&quot;2.0.0&quot;</span><span class="p">,</span>
  <span class="nt">&quot;tasks&quot;</span><span class="p">:</span> <span class="p">[</span>
    <span class="p">{</span>
      <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;shell&quot;</span><span class="p">,</span>
      <span class="nt">&quot;command&quot;</span><span class="p">:</span> <span class="s2">&quot;${command:python.interpreterPath}&quot;</span><span class="p">,</span>
      <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;setup.py&quot;</span><span class="p">,</span> <span class="s2">&quot;bdist_wheel&quot;</span><span class="p">],</span>
      <span class="nt">&quot;isBackground&quot;</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
      <span class="nt">&quot;options&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">},</span>
      <span class="nt">&quot;label&quot;</span><span class="p">:</span> <span class="s2">&quot;Build Wheel&quot;</span><span class="p">,</span>
      <span class="nt">&quot;group&quot;</span><span class="p">:</span> <span class="p">{</span>
        <span class="nt">&quot;kind&quot;</span><span class="p">:</span> <span class="s2">&quot;build&quot;</span><span class="p">,</span>
        <span class="nt">&quot;isDefault&quot;</span><span class="p">:</span> <span class="kc">true</span>
      <span class="p">},</span>
<span class="hll">      <span class="nt">&quot;dependsOn&quot;</span><span class="p">:</span> <span class="p">[</span><span class="s2">&quot;Build Source&quot;</span><span class="p">]</span>
</span>    <span class="p">}</span>
  <span class="p">]</span>
<span class="p">}</span>
</code></pre></div>
<p>The next time you run this task, it will run all dependent tasks first.</p>
<p>If you have multiple tasks that this task depends on and they can be run in parallel, add <code>"dependsOrder": "parallel"</code> to the task configuration.</p>
</section><section class="section3" id="using-tasks-to-run-tox"><h3>Using Tasks to Run Tox<a class="headerlink" href="#using-tasks-to-run-tox" title="Permanent link"></a></h3>
<p>Now you&rsquo;ll explore <a href="https://tox.readthedocs.io/en/latest/">tox</a>, which is a tool that aims to automate and standardize testing in Python. The Python extension for Visual Studio Code doesn&rsquo;t come with tox integration. Instead, you can use the tasks system to set tox as the default test task.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Tip:</strong> If you want to get started quickly with tox, then install <code>tox</code> with <code>pip</code> and run the <code>tox-quickstart</code> command:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>python -m pip install tox
<span class="gp">$ </span>tox-quickstart
</code></pre></div>
<p>This will prompt you through the steps of creating a <a href="https://tox.readthedocs.io/en/latest/config.html">tox configuration file</a>.</p>
</div>
<p>To automate running tox with your tox configuration, add the following task to <code>tasks.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
  <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;shell&quot;</span><span class="p">,</span>
  <span class="nt">&quot;command&quot;</span><span class="p">:</span> <span class="s2">&quot;tox&quot;</span><span class="p">,</span>
  <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[],</span>
  <span class="nt">&quot;isBackground&quot;</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
  <span class="nt">&quot;options&quot;</span><span class="p">:</span> <span class="p">{</span><span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">},</span>
  <span class="nt">&quot;label&quot;</span><span class="p">:</span> <span class="s2">&quot;Run tox&quot;</span><span class="p">,</span>
  <span class="nt">&quot;group&quot;</span><span class="p">:</span> <span class="p">{</span>
      <span class="nt">&quot;kind&quot;</span><span class="p">:</span> <span class="s2">&quot;test&quot;</span><span class="p">,</span>
      <span class="nt">&quot;isDefault&quot;</span><span class="p">:</span> <span class="kc">true</span>
  <span class="p">}</span>
<span class="p">}</span>
</code></pre></div>
<p>You can run this task using <code>Tasks: Run Test Task</code> from the Command Palette, and the task will execute tox with the output within the <em>Terminal</em> tab:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-tox.27ac247b5c4c.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-tox.27ac247b5c4c.png" width="1944" height="532" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-tox.27ac247b5c4c.png&amp;w=486&amp;sig=c3de1540447fbaf8d7a074fee6d265b5a9fa3ef9 486w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-tox.27ac247b5c4c.png&amp;w=972&amp;sig=451856d9074e8025845ccdc2b800906a78515a2c 972w, https://files.realpython.com/media/vscode-tox.27ac247b5c4c.png 1944w" sizes="75vw" alt="VS Code running Tox" data-asset="3795" /></a></figure>
<p>If you have a few tasks and need to run them often, it&rsquo;s time to explore a great extension that adds some shortcuts in the UI for running configured tasks.</p>
</section><section class="section3" id="using-the-task-explorer-extension"><h3>Using the Task Explorer Extension<a class="headerlink" href="#using-the-task-explorer-extension" title="Permanent link"></a></h3>
<p>The <a href="https://marketplace.visualstudio.com/items?itemName=spmeesseman.vscode-taskexplorer">Task Explorer extension (<code>spmeesseman.vscode-taskexplorer</code>)</a> adds simple UI controls to run your pre-configured tasks. Once installed, <em>Task Explorer</em> will be a panel within the <em>Explorer</em> view. It scans your project to auto-discover tasks for <code>npm</code>, <code>make</code>, <code>gulp</code>, and many other build tools. You can find your tasks under the <em>vscode</em> group:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-task-explorer.279e381a014a.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-task-explorer.279e381a014a.png" width="1782" height="1114" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-task-explorer.279e381a014a.png&amp;w=445&amp;sig=18dd9e6f5cefc9b7dc4d2903c6fc02e8d33063db 445w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-task-explorer.279e381a014a.png&amp;w=891&amp;sig=5fca5cb1010f2ff35a16639d733301c83fcbf293 891w, https://files.realpython.com/media/vscode-task-explorer.279e381a014a.png 1782w" sizes="75vw" alt="VS Code Task Explorer" data-asset="3796" /></a></figure>
<p>Click the arrow next to any task to execute it, and click the refresh icon at the top if you change your task&rsquo;s configuration.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section2" id="debugging-your-python-scripts-in-visual-studio-code"><h2>Debugging Your Python Scripts in Visual Studio Code<a class="headerlink" href="#debugging-your-python-scripts-in-visual-studio-code" title="Permanent link"></a></h2>
<p>The Python extension for Visual Studio Code comes bundled with a powerful debugger that supports local and remote <a href="https://code.visualstudio.com/docs/editor/debugging">debugging</a>.</p>
<p>The simplest way to run and debug a simple Python script is going to the <em>Run → Start Debugging</em> menu and choosing <em>Python File</em> from the selection. This will execute the current file using the configured Python interpreter.</p>
<p>You can set breakpoints anywhere in the code by clicking in the gutter to the left of the line number. When breakpoints are hit as the code executes, the code will pause and wait for instruction:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-debug-breakpoint.eafdcb77613d.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-debug-breakpoint.eafdcb77613d.png" width="1622" height="414" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-breakpoint.eafdcb77613d.png&amp;w=405&amp;sig=5cf51044b2624b190026c80ed27a626b3966403d 405w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-breakpoint.eafdcb77613d.png&amp;w=811&amp;sig=91e57247a47db82fe606084709bca924b06ae105 811w, https://files.realpython.com/media/vscode-debug-breakpoint.eafdcb77613d.png 1622w" sizes="75vw" alt="VS Code at breakpoint" data-asset="3798" /></a></figure>
<p>The debugger adds a menu of controls: <em>Continue</em>, <em>Step Over</em>, <em>Step Into</em>, <em>Step Out</em>, <em>Restart</em>, and <em>Stop Execution</em>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-debug-controls.82b8a69e3b32.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-debug-controls.82b8a69e3b32.png" width="816" height="114" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-controls.82b8a69e3b32.png&amp;w=204&amp;sig=1d95f2fbf7bfbee1f49f3544d48bec865cdef33d 204w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-controls.82b8a69e3b32.png&amp;w=408&amp;sig=0f17bf1d78521089398be59d223f1a818e2c516b 408w, https://files.realpython.com/media/vscode-debug-controls.82b8a69e3b32.png 816w" sizes="75vw" alt="VS Code Debug Controls" data-asset="3799" /></a></figure>
<p>On the left panel, you can perform common debugging actions, such as exploring local and global variables and Python&rsquo;s call stack. You can also <strong>set watches</strong>, which you&rsquo;ll learn more about in the next section.</p>
<section class="section3" id="setting-watches"><h3>Setting Watches<a class="headerlink" href="#setting-watches" title="Permanent link"></a></h3>
<p><strong>Watches</strong> are expressions that persist between debugging sessions. When you stop execution and start debugging again, you&rsquo;ll keep any watches from your last session.</p>
<p>You can add a variable to the <em>Watch</em> panel from the <em>Variables</em> panel by right-clicking a variable and selecting <em>Add to Watch</em>.</p>
<p>You can also add any Python expression to the <em>Watch</em> list by clicking the <em>+</em> icon. Expressions can contain:</p>
<ul>
<li>Small Python expressions, such as <code>x == 3</code></li>
<li>Function calls, such as <code>var.upper()</code></li>
<li>Comparisons</li>
</ul>
<p>You&rsquo;ll get the current result of each expression in real time whenever a breakpoint is hit. VS Code will also update the value of each watch while you step through your debugging session:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-debug-watches.1188719a20cc.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-debug-watches.1188719a20cc.png" width="960" height="350" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-watches.1188719a20cc.png&amp;w=240&amp;sig=7fd3fd004f45ba4051b56349ad19e56a8e3d8877 240w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-debug-watches.1188719a20cc.png&amp;w=480&amp;sig=4e26d64132e51e215bc166cadfcb077fcc8e838b 480w, https://files.realpython.com/media/vscode-debug-watches.1188719a20cc.png 960w" sizes="75vw" alt="VS Code Watches Panel" data-asset="3800" /></a></figure>
<p>You can expand complex types like dictionaries and objects using the arrow on the left.</p>
<p>So far, you&rsquo;ve seen the debugger for a single Python file, but many Python applications are modules or require special commands to start.</p>
</section><section class="section3" id="configuring-a-launch-file"><h3>Configuring a Launch File<a class="headerlink" href="#configuring-a-launch-file" title="Permanent link"></a></h3>
<p>VS Code has a configuration file for launch profiles, <code>.vscode/launch.json</code>. The Python debugger for VS Code can start any launch configuration and attach the debugger to it.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> To see the expected result of the upcoming configuration, you need to have a working <a href="https://realpython.com/fastapi-python-web-apis/">FastAPI project</a> set up and the <a href="https://realpython.com/python-async-features/">async</a> web server <a href="https://www.uvicorn.org">uvicorn</a> installed in the Python environment you&rsquo;re using.</p>
</div>
<p>For an example of working with launch profiles in VS Code, you&rsquo;ll explore how to use the ASGI server <code>uvicorn</code> to start a <a href="http://fastapi.tiangolo.com/">FastAPI</a> application. Normally, you might just use the command line:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>python -m uvicorn example_app.main:app
</code></pre></div>
<p>Instead, you could set up an equivalent launch configuration in <code>launch.json</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
  <span class="nt">&quot;configurations&quot;</span><span class="p">:</span> <span class="p">[</span>
    <span class="p">{</span>
      <span class="nt">&quot;name&quot;</span><span class="p">:</span> <span class="s2">&quot;Python: FastAPI&quot;</span><span class="p">,</span>
      <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;python&quot;</span><span class="p">,</span>
      <span class="nt">&quot;request&quot;</span><span class="p">:</span> <span class="s2">&quot;launch&quot;</span><span class="p">,</span>
      <span class="nt">&quot;module&quot;</span><span class="p">:</span> <span class="s2">&quot;uvicorn&quot;</span><span class="p">,</span>
      <span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">,</span>
      <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span>
          <span class="s2">&quot;example_app.main:app&quot;</span>
      <span class="p">],</span>
    <span class="p">}</span>
  <span class="p">]</span>
<span class="p">}</span>
</code></pre></div>
<p>Here, you set <code>"type"</code> in the configuration to <code>"python"</code>, which tells VS Code to use the Python debugger. You also set <code>"module"</code> to specify the Python module to run, which in this case is <code>"uvicorn"</code>. You can provide any number of arguments under <code>"args"</code>. If your application requires environment variables, you can also set those using the <code>env</code> parameter.</p>
<p>Once you&rsquo;ve added this configuration, you should find your new launch configuration ready to start under the <em>Run and Debug</em> panel:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-run-launch.f6590d7a60d1.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-run-launch.f6590d7a60d1.png" width="636" height="288" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-run-launch.f6590d7a60d1.png&amp;w=159&amp;sig=356dc6d9898b19fc04d0598560ebde3049cd7221 159w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-run-launch.f6590d7a60d1.png&amp;w=318&amp;sig=57a4831877bdaf040c969fe1f21fd8bd79104cd5 318w, https://files.realpython.com/media/vscode-run-launch.f6590d7a60d1.png 636w" sizes="75vw" alt="VS Code Launch Selection" data-asset="3801" /></a></figure>
<p>Whatever you configured as the first launch configuration will run when you press <span class="keys"><kbd class="key-f5">F5</kbd></span> or select <em>Run → Start Debugging</em> from the top menu.</p>
<p>If VS Code doesn&rsquo;t automatically select the right Python environment for you, then you can also declare an explicit path to the appropriate Python interpreter as an option in your <code>.vscode/launch.json</code> file:</p>
<div class="highlight json"><pre><span></span><code><span class="linenos"> 1</span><span class="p">{</span>
<span class="linenos"> 2</span>  <span class="nt">&quot;configurations&quot;</span><span class="p">:</span> <span class="p">[</span>
<span class="linenos"> 3</span>    <span class="p">{</span>
<span class="linenos"> 4</span>      <span class="nt">&quot;name&quot;</span><span class="p">:</span> <span class="s2">&quot;Python: FastAPI&quot;</span><span class="p">,</span>
<span class="linenos"> 5</span>      <span class="nt">&quot;type&quot;</span><span class="p">:</span> <span class="s2">&quot;python&quot;</span><span class="p">,</span>
<span class="linenos"> 6</span><span class="hll">      <span class="nt">&quot;python&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}/venv/bin/python&quot;</span><span class="p">,</span>
</span><span class="linenos"> 7</span>      <span class="nt">&quot;request&quot;</span><span class="p">:</span> <span class="s2">&quot;launch&quot;</span><span class="p">,</span>
<span class="linenos"> 8</span>      <span class="nt">&quot;module&quot;</span><span class="p">:</span> <span class="s2">&quot;uvicorn&quot;</span><span class="p">,</span>
<span class="linenos"> 9</span>      <span class="nt">&quot;cwd&quot;</span><span class="p">:</span> <span class="s2">&quot;${workspaceFolder}&quot;</span><span class="p">,</span>
<span class="linenos">10</span>      <span class="nt">&quot;args&quot;</span><span class="p">:</span> <span class="p">[</span>
<span class="linenos">11</span>          <span class="s2">&quot;example_app.main:app&quot;</span>
<span class="linenos">12</span>      <span class="p">],</span>
<span class="linenos">13</span>    <span class="p">}</span>
<span class="linenos">14</span>  <span class="p">]</span>
<span class="linenos">15</span><span class="p">}</span>
</code></pre></div>
<p>You can add the path to your Python interpreter as a new entry with the name <code>"python"</code>. In this example, the interpreter is located in a Python virtual environment named <code>venv</code> that you created at the root of your workspace folder. If there&rsquo;s a different Python interpreter you&rsquo;d like to use, you can define the path to it by editing the path shown in line 6 to fit your setup.</p>
<div><div class="rounded border border-light" style="display:block;position:relative;"><div style="display:block;width:100%;padding-top:12.5%;"></div><div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div></div><a class="small text-muted" href="/account/join/" rel="nofollow"><i aria-hidden="true" class="fa fa-info-circle"> </i> Remove ads</a></div></section></section><section class="section2" id="mastering-remote-development"><h2>Mastering Remote Development<a class="headerlink" href="#mastering-remote-development" title="Permanent link"></a></h2>
<p>VS Code supports three remote development profiles:</p>
<ol>
<li>Containers</li>
<li>Remote Hosts over SSH</li>
<li>Windows Subsystem for Linux (WSL)</li>
</ol>
<p>All three options are provided by the <a href="https://marketplace.visualstudio.com/items?itemName=ms-vscode-remote.vscode-remote-extensionpack">Remote Development extension pack (<code>ms-vscode-remote.vscode-remote-extensionpack</code>)</a>. You need to install this extension pack for the remote debugging features to display in VS Code.</p>
<section class="section3" id="remote-development-with-containers"><h3>Remote Development With Containers<a class="headerlink" href="#remote-development-with-containers" title="Permanent link"></a></h3>
<p>You need to install the Docker runtime on your machine to use remote debugging for containers. If you don&rsquo;t already have Docker installed, you can download it from <a href="https://www.docker.com/products/docker-desktop">the Docker website</a>.</p>
<p>Once Docker is running, go to the <em>Remote Explorer</em> tab on the left navigation menu. Change the <em>Remote Explorer</em> dropdown to <em>Containers</em>, and you&rsquo;ll see a view with panels:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/131485209-7fbb0f9a-22b7-4828-a477-8af33c0be91a.998dcdb18a09.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/131485209-7fbb0f9a-22b7-4828-a477-8af33c0be91a.998dcdb18a09.png" width="3008" height="1692" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/131485209-7fbb0f9a-22b7-4828-a477-8af33c0be91a.998dcdb18a09.png&amp;w=752&amp;sig=e90352f5af8bf2aae55937bef04ac58f8cad0a0c 752w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/131485209-7fbb0f9a-22b7-4828-a477-8af33c0be91a.998dcdb18a09.png&amp;w=1504&amp;sig=c50f233b83e7a8680502906917133baacfa18d88 1504w, https://files.realpython.com/media/131485209-7fbb0f9a-22b7-4828-a477-8af33c0be91a.998dcdb18a09.png 3008w" sizes="75vw" alt="VS Code Remote Container Window" data-asset="3953" /></a></figure>
<p>These panels aren&rsquo;t populated if you have a fresh Docker install.</p>
<p>If you already have Docker images installed and running, the three panels might be populated:</p>
<ol>
<li><strong>Containers:</strong> A navigation panel to show the development containers within this workspace or links to some quick-start steps</li>
<li><strong>The name of your container (if running):</strong> The attributes and volume mounts of the running container</li>
<li><strong>DevVolumes:</strong> A list of dev volumes you can edit and mount to modify code</li>
</ol>
<p>For example, if you installed the <a href="https://github.com/Microsoft/vscode-remote-try-python">Try Out Development Container: Python</a> by following the steps outlined in VS Code&rsquo;s <a href="https://code.visualstudio.com/docs/remote/containers-tutorial#_get-the-sample">containers tutorial</a>, your VS Code <em>Remote Explorer</em> tab will show the name of the running container across the panels mentioned earlier:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-remote-try-python.8ca72bda9ccd.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-remote-try-python.8ca72bda9ccd.png" width="3008" height="1692" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-remote-try-python.8ca72bda9ccd.png&amp;w=752&amp;sig=947cf1f71f7de8e7c044162771b80f4a4a358e05 752w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-remote-try-python.8ca72bda9ccd.png&amp;w=1504&amp;sig=0e045ff960f67fca31acaee831d20d2502f82145 1504w, https://files.realpython.com/media/vscode-remote-try-python.8ca72bda9ccd.png 3008w" sizes="75vw" alt="The Remote Explorer panel in VS Code showing a running development container" data-asset="3957" /></a></figure>
<p>Use these panels as a quick way of managing any Docker containers that your project depends on.</p>
<p>In general, there are three primary ways of running the Remote Containers extension:</p>
<ol>
<li>Attach to an existing running container to make quick changes</li>
<li>Create a <a href="https://code.visualstudio.com/docs/remote/create-dev-container#_create-a-devcontainerjson-file"><code>.devcontainer/devcontainer.json</code> file</a> and open the workspace as a remote container</li>
<li>Run the <code>Remote-Containers: Reopen in Container</code> command and select the Python 3 image</li>
</ol>
<p>Creating a <code>.devcontainer/devcontainer.json</code> file has significant benefits over simply opening a container:</p>
<ul>
<li>Dev containers support <a href="https://github.com/features/codespaces">GitHub Codespaces</a></li>
<li>Dev containers support the launch profiles and task configurations shown in this tutorial</li>
</ul>
<p>If you&rsquo;re planning on working within containers and VS Code a lot, spending the extra time to create a development container will pay off.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> You can learn how to <a href="https://code.visualstudio.com/docs/remote/create-dev-container">create a development container</a> in more detail by reading through the official VS Code documentation.</p>
</div>
<p>A quick way to get started using a dev container is by creating it from your current workspace:</p>
<ol>
<li>Run the <code>Remote-Containers: Reopen in Container</code> command from the Command Palette.</li>
<li>Select Python 3 and then select the required version of Python.</li>
<li>Accept the default suggested version of Node.js.</li>
</ol>
<p>VS Code will then port your existing workspace and create a <code>.devcontainer/devcontainer.json</code> configuration based upon a generic <a href="https://docs.docker.com/engine/reference/builder/"><code>Dockerfile</code></a> for Python.</p>
<p>Dev containers have two required files:</p>
<ol>
<li><strong><code>.devcontainer/devcontainer.json</code></strong>, which specifies all the VS Code requirements, such as which extensions are needed and what settings to use</li>
<li><strong><code>Dockerfile</code></strong>, which specifies what commands will build the environment</li>
</ol>
<p>In the default setup, <code>Dockerfile</code> is inside the <code>.devcontainer/</code> directory. If your project already has a <code>Dockerfile</code>, you can reuse that by changing the path in <code>.devcontainer/devcontainer.json</code>.</p>
<p>You&rsquo;ll use the defaults inside <code>.devcontainer/devcontainer.json</code> to specify:</p>
<ul>
<li>The <strong>path</strong> to a <code>Dockerfile</code></li>
<li>A <strong>name</strong> for the container</li>
<li>The VS Code <strong>settings</strong> to apply</li>
<li>Any required VS Code <strong>extensions</strong> to install</li>
<li>Any post-create <strong>commands</strong> you want to run, like <code>python -m pip install &lt;package&gt;</code>, for example</li>
</ul>
<p>If your application requires additional packages from PyPI, change <code>.devcontainer/devcontainer.json</code> and uncomment the line specifying <code>"postCreateCommand"</code>:</p>
<div class="highlight json"><pre><span></span><code><span class="p">{</span>
  <span class="err">...</span>
  <span class="err">//</span> <span class="err">Use</span> <span class="err">&#39;pos</span><span class="kc">t</span><span class="err">Crea</span><span class="kc">te</span><span class="err">Comma</span><span class="kc">n</span><span class="err">d&#39;</span> <span class="kc">t</span><span class="err">o</span> <span class="err">ru</span><span class="kc">n</span> <span class="err">comma</span><span class="kc">n</span><span class="err">ds</span> <span class="err">a</span><span class="kc">fter</span> <span class="kc">t</span><span class="err">he</span> <span class="err">Co</span><span class="kc">nta</span><span class="err">i</span><span class="kc">ner</span> <span class="err">is</span> <span class="err">crea</span><span class="kc">te</span><span class="err">d.</span>
  <span class="nt">&quot;postCreateCommand&quot;</span><span class="p">:</span> <span class="s2">&quot;python3 -m pip install -r requirements.txt&quot;</span><span class="p">,</span>
<span class="p">}</span>
</code></pre></div>
<p>You can also add options for port forwarding if you&rsquo;re developing an application that provides network services, like a web app. For the full list of options, you can go through the <a href="https://code.visualstudio.com/docs/remote/devcontainerjson-reference"><code>devcontainer.json</code> reference</a>.</p>
<p>After making changes to either the <code>Dockerfile</code> or the devcontainer specification, rebuild the container from the Remote Explorer by right-clicking the running container and selecting <em>Rebuild Container</em>:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/screenshot_2021-09-21_at_09.39.52.bec0f2338066.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/screenshot_2021-09-21_at_09.39.52.bec0f2338066.png" width="1452" height="1202" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_09.39.52.bec0f2338066.png&amp;w=363&amp;sig=074b21fca1fa3061d4c2fee2f1140040be55ff06 363w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_09.39.52.bec0f2338066.png&amp;w=726&amp;sig=fdfc9efa1aac81ad4abfa6d529dd61104ebb98ce 726w, https://files.realpython.com/media/screenshot_2021-09-21_at_09.39.52.bec0f2338066.png 1452w" sizes="75vw" alt="VS Code Rebuild Container" data-asset="3954" /></a></figure>
<p>By doing this, you&rsquo;ll rebuild the Docker container with any changes to the configuration and <code>Dockerfile</code>.</p>
<p>Beyond the functionality of the Remote Development extension pack&rsquo;s extension for remote debugging, there&rsquo;s a Docker extension for VS Code. You&rsquo;ll cover this extension at the end of the tutorial and find even more features.</p>
</section><section class="section3" id="remote-development-with-ssh"><h3>Remote Development With SSH<a class="headerlink" href="#remote-development-with-ssh" title="Permanent link"></a></h3>
<p>By running <code>Remote-SSH: Open SSH Configuration File</code> in the Command Palette, you can open up the local SSH configuration file. This is a standard <a href="https://linux.die.net/man/5/ssh_config">SSH config</a> file for you to list hosts, ports, and paths to private keys. The <code>IdentityFile</code> option defaults to <code>~/.ssh/id_rsa</code>, so the best way to authenticate is a private and public key pair.</p>
<p>Here&rsquo;s an example configuration of two hosts:</p>
<div class="highlight config"><pre><span></span><code>Host 192.168.86.30
  HostName 192.168.86.30
  User development
  IdentityFile ~/path/to/rsa

Host Test-Box
  HostName localhost
  User vagrant
  Port 2222
</code></pre></div>
<p>Once you save the configuration file, the <em>Remote Explorer</em> tab will list those SSH hosts under the <em>SSH Targets</em> dropdown option:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-ssh-targets.f90ac5736e62.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-ssh-targets.f90ac5736e62.png" width="916" height="356" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ssh-targets.f90ac5736e62.png&amp;w=229&amp;sig=b6cbaa5e1a87759c2817990019c4e90f4e02a646 229w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ssh-targets.f90ac5736e62.png&amp;w=458&amp;sig=36737ea5fca9d90a45c60fc558093dfdece8d64b 458w, https://files.realpython.com/media/vscode-ssh-targets.f90ac5736e62.png 916w" sizes="75vw" alt="VS Code SSH Targets" data-asset="3806" /></a></figure>
<p>To connect to that server, click on <em>Connect to Host in New Window</em>, which is the icon to the right of any host. This will open a new VS Code window with the remote host.</p>
<p>Once connected, click <em>Open Folder</em> under the <em>Explorer</em> view. VS Code will show you a special folder navigation menu that displays the available folders on the remote host. Navigate to the folder where your code is located, and you can start a new workspace under that directory:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-ssh-select.c40298afd273.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-ssh-select.c40298afd273.png" width="2189" height="1167" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ssh-select.c40298afd273.png&amp;w=547&amp;sig=e007023d34ec967bba00b20eebb3eee83ae401f8 547w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-ssh-select.c40298afd273.png&amp;w=1094&amp;sig=1ddde473134af447c1fd1b8bb73e77dd02537593 1094w, https://files.realpython.com/media/vscode-ssh-select.c40298afd273.png 2189w" sizes="75vw" alt="VS Code remote navigation" data-asset="3807" /></a></figure>
<p>In this remote workspace, you can edit and save any files live on the remote server. The <em>Terminal</em> tab is automatically set as the SSH terminal for the remote host if you need to run any additional commands.</p>
</section><section class="section3" id="remote-development-with-wsl"><h3>Remote Development With WSL<a class="headerlink" href="#remote-development-with-wsl" title="Permanent link"></a></h3>
<p><a href="https://docs.microsoft.com/en-us/windows/wsl/">Windows Subsystem for Linux</a>, or <strong>WSL</strong>, is a component for Microsoft Windows that enables users to run any number of Linux distros on their Windows OS without the need for a separate hypervisor.</p>
<p>VS Code supports WSL as a remote target, so you can run VS Code for Windows and develop for Linux under WSL.</p>
<p>Using WSL with VS Code first requires that WSL is installed. Once WSL is installed, you need to have at least one distro available.</p>
<p>The easiest way to install WSL on the latest version of Windows 10 is to open a command prompt and run:</p>
<div class="highlight doscon"><pre><span></span><code><span class="gp">C:\&gt;</span> wsl --install
</code></pre></div>
<p>The <code>--install</code> command performs the following actions:</p>
<ul>
<li>Enables the optional WSL and Virtual Machine Platform components</li>
<li>Downloads and installs the latest Linux Kernel</li>
<li>Sets WSL 2 as the default</li>
<li>Downloads and installs a Linux distribution, possibly requiring a reboot of your machine</li>
</ul>
<p>Once you&rsquo;ve successfully set up WSL on your computer, you also need to install the <a href="https://marketplace.visualstudio.com/items?itemName=ms-vscode-remote.remote-wsl">Remote - WSL (<code>ms-vscode-remote.remote-wsl</code>)</a> extension for VS Code. After that, you&rsquo;re ready to use WSL in Visual Studio Code.</p>
<p>If you already have code in WSL, run <code>Remote-WSL: Open Folder in WSL</code> from the Command Palette in VS Code. Select the target directory for your code in the Linux subsystem.</p>
<p>If your code was checked out in Windows, run <code>Remote-WSL: Reopen Folder in WSL</code> from the Command Palette.</p>
<p>The Remote Explorer will remember your configured WSL targets and let you reopen them quickly from the <em>WSL Targets</em> dropdown in the <em>Remote Explorer</em> view:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-wsl-working.6dc8198cede7.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-wsl-working.6dc8198cede7.png" width="1843" height="1074" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-wsl-working.6dc8198cede7.png&amp;w=460&amp;sig=70857cd6325efe0e07f20b0cbcd9ef8ba4c59c12 460w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-wsl-working.6dc8198cede7.png&amp;w=921&amp;sig=97ea8c72b806313fa3ff9b8a9361a874b5be8dc2 921w, https://files.realpython.com/media/vscode-wsl-working.6dc8198cede7.png 1843w" sizes="75vw" alt="VS Code with WSL" data-asset="3811" /></a></figure>
<p>If you want a reproducible environment, consider creating a <code>Dockerfile</code> instead of working directly on the WSL host.</p>
</section></section><section class="section2" id="working-with-data-science-tools"><h2>Working With Data Science Tools<a class="headerlink" href="#working-with-data-science-tools" title="Permanent link"></a></h2>
<p>VS Code is great for working on Python for application development and web development. It also has a powerful set of extensions and tools for working with data science projects.</p>
<p>So far, you&rsquo;ve mostly covered the Python extension for VS Code. There&rsquo;s also the <strong>Jupyter Notebooks extension</strong>, which integrates the IPython kernel and a notebook editor into VS Code.</p>
<section class="section3" id="installing-the-jupyter-notebook-extension"><h3>Installing the Jupyter Notebook Extension<a class="headerlink" href="#installing-the-jupyter-notebook-extension" title="Permanent link"></a></h3>
<p>To get started with Jupyter Notebooks on VS Code, you&rsquo;ll need the <a href="https://marketplace.visualstudio.com/items?itemName=ms-toolsai.jupyter">Jupyter Extension (<code>ms-toolsai.jupyter</code>)</a>.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> Jupyter Notebooks support is now bundled with the Python extension, so don&rsquo;t be surprised if you already have it installed.</p>
</div>
<p>Jupyter Notebooks supports <code>pip</code> as the package manager, as well as <code>conda</code> from <a href="https://www.anaconda.com/products/individual">the Anaconda distribution</a>.</p>
<p>Data science libraries for Python often require compiled modules written in C and C++. You should use <code>conda</code> as the package manager if you&rsquo;re using a lot of third-party packages because the Anaconda distribution has resolved the build dependencies on your behalf, making it easier to install packages.</p>
</section><section class="section3" id="getting-started-with-jupyter-notebooks-in-vs-code"><h3>Getting Started With Jupyter Notebooks in VS Code<a class="headerlink" href="#getting-started-with-jupyter-notebooks-in-vs-code" title="Permanent link"></a></h3>
<p>For this example, you&rsquo;ll open a series of Jupyter Notebooks on <a href="https://github.com/calebmadrigal/FourierTalkOSCON">wave transformations</a>. Download the repo&rsquo;s <code>.zip/</code> folder and unzip it, or <a href="https://docs.github.com/en/repositories/creating-and-managing-repositories/cloning-a-repository">clone the GitHub repo</a> and open it with VS Code. The steps described further down will also work with any other workspace containing <code>.ipynb</code> notebook files.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> The rest of this section uses the <code>conda</code> package manager. You&rsquo;ll need to have <a href="https://docs.anaconda.com/anaconda/install/index.html">Anaconda installed</a> if you want to use the commands shown in this section.</p>
</div>
<p>In VS Code, you can use any existing <code>conda</code> environment. Instead of installing packages into the base environment, you can create a <code>conda</code> environment specifically for VS Code from your terminal:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>conda create --name vscode <span class="nv">python</span><span class="o">=</span><span class="m">3</span>.8
</code></pre></div>
<p>After you&rsquo;ve created the <code>conda</code> environment named <code>vscode</code>, you can install some common dependencies into it:</p>
<div class="highlight sh"><pre><span></span><code><span class="gp">$ </span>conda install -n vscode -y numpy scipy pandas matplotlib ipython ipykernel ipympl
</code></pre></div>
<p>Once you&rsquo;ve installed the dependencies, run the <code>Python: Select Interpreter</code> command from the VS Code Command Palette and search for <code>vscode</code> to select the new <code>conda</code> environment:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/screenshot_2021-09-21_at_10.10.43.87b02bc450a9.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/screenshot_2021-09-21_at_10.10.43.87b02bc450a9.png" width="1464" height="298" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_10.10.43.87b02bc450a9.png&amp;w=366&amp;sig=25bbe025b9979ce00496beedc9d12a3ee1108d06 366w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_10.10.43.87b02bc450a9.png&amp;w=732&amp;sig=9bcff4bed2756d3c2e51728c4a77180a458fac79 732w, https://files.realpython.com/media/screenshot_2021-09-21_at_10.10.43.87b02bc450a9.png 1464w" sizes="75vw" alt="VS Code select interpreter" data-asset="3956" /></a></figure>
<p>This selection will set your VS Code to use the Python interpreter from your <code>conda</code> environment, <code>vscode</code>.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> If the <code>conda</code> environment is not available in the list, you may need to reload the window by running the <code>Developer: Reload Window</code> command from the Command Palette.</p>
</div>
<p>Once selected, open a notebook in VS Code and click the <em>Select Kernel</em> button on the right or run the <code>Notebook: Select Notebook Kernel</code> command from the Command Palette. Type <code>vscode</code> to select the newly created <code>conda</code> environment with the dependencies installed:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/screenshot_2021-09-21_at_10.11.30.39885015a29d.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/screenshot_2021-09-21_at_10.11.30.39885015a29d.png" width="1454" height="192" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_10.11.30.39885015a29d.png&amp;w=363&amp;sig=7ed8c50bef20ed65bcb824213af83e65c17ce757 363w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/screenshot_2021-09-21_at_10.11.30.39885015a29d.png&amp;w=727&amp;sig=729bae6618251b32cc0c431cd2a1388e04a8431f 727w, https://files.realpython.com/media/screenshot_2021-09-21_at_10.11.30.39885015a29d.png 1454w" sizes="75vw" alt="VS Code Select Kernel" data-asset="3813" /></a></figure>
<p>Selecting your new <code>conda</code> environment as the kernel for your notebook will give your notebook access to all the dependencies that you installed in that environment. It&rsquo;s necessary for executing the code cells.</p>
<p>Once the kernel is selected, you can <a href="https://code.visualstudio.com/docs/datascience/jupyter-notebooks#_running-cells">run any or all of the cells</a> and see the output of the operations displayed right inside VS Code:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-jupyter.8adde9214168.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-jupyter.8adde9214168.png" width="3505" height="2218" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-jupyter.8adde9214168.png&amp;w=876&amp;sig=c85fa172305ad9a59e204e5a3f5af611bd30f9ac 876w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-jupyter.8adde9214168.png&amp;w=1752&amp;sig=d00fef929ec7b724e2c0ee70fc40080133144d44 1752w, https://files.realpython.com/media/vscode-jupyter.8adde9214168.png 3505w" sizes="75vw" alt="VS Code Jupyter" data-asset="3814" /></a></figure>
<p>Once the notebook has executed, the Jupyter Extension will make any of the intermediate variables such as lists, NumPy arrays, and pandas DataFrames available in the <em>Jupyter: Variables</em> view:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-variable-view.05e4f0229696.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-variable-view.05e4f0229696.png" width="1824" height="714" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-variable-view.05e4f0229696.png&amp;w=456&amp;sig=a9f23b3fadd6c1dbda685f7d59aa20a859214a82 456w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-variable-view.05e4f0229696.png&amp;w=912&amp;sig=1a46345d3ee91f124220cdef357d9ac16cdce747 912w, https://files.realpython.com/media/vscode-variable-view.05e4f0229696.png 1824w" sizes="75vw" alt="VS Code Variable View" data-asset="3816" /></a></figure>
<p>You can bring this view into focus by clicking the <em>Variables</em> button at the top of the notebook or by running the <code>Jupyter: Focus on Variables View</code> command.</p>
<p>For the more complex variables, choose the icon to open the data in the data viewer.</p>
</section><section class="section3" id="using-the-data-viewer"><h3>Using the Data Viewer<a class="headerlink" href="#using-the-data-viewer" title="Permanent link"></a></h3>
<p>The Jupyter Extension comes with a data viewer designed for viewing and filtering 2D arrays, such as lists, NumPy&rsquo;s <code>ndarray</code>, and pandas DataFrames:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-data-viewer.33472291d009.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-data-viewer.33472291d009.png" width="1694" height="882" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-data-viewer.33472291d009.png&amp;w=423&amp;sig=08dde0f86b02d77293012fa032efd372d882e923 423w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-data-viewer.33472291d009.png&amp;w=847&amp;sig=051f38cc3d5cf375e1485e9314e9a296aea9d05c 847w, https://files.realpython.com/media/vscode-data-viewer.33472291d009.png 1694w" sizes="75vw" alt="VS Code Data Viewer" data-asset="3815" /></a></figure>
<p>To access the data viewer, you can expand complex variables inside the variables view by clicking on <em>Show variable in data viewer</em>. This option is represented by an icon shown on the left of a row that represents a complex variable:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/advanced-vscode-show-data-viewer.7e6d5f685022.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/advanced-vscode-show-data-viewer.7e6d5f685022.png" width="3008" height="1692" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/advanced-vscode-show-data-viewer.7e6d5f685022.png&amp;w=752&amp;sig=024b76b02f1934f6c1fb29beb16840abe7ac09a2 752w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/advanced-vscode-show-data-viewer.7e6d5f685022.png&amp;w=1504&amp;sig=55d9cdb67660812edaebdfb92530998813476bd6 1504w, https://files.realpython.com/media/advanced-vscode-show-data-viewer.7e6d5f685022.png 3008w" sizes="75vw" alt="Symbol for showing the data viewer for more complex variables in the Jupyter variables view" data-asset="3935" /></a></figure>
<p>The data viewer supports inline filtering and paging for large data sets. If you&rsquo;re plotting large data sets in Matplotlib, the Jupyter Extension supports <a href="https://matplotlib.org/stable/api/widgets_api.html">Matplotlib widgets</a> instead of SVG rendering.</p>
</section><section class="section3" id="using-the-rainbow-csv-extension"><h3>Using the Rainbow CSV Extension<a class="headerlink" href="#using-the-rainbow-csv-extension" title="Permanent link"></a></h3>
<p>If you work with CSV or TSV input data, there&rsquo;s a useful extension called <a href="https://marketplace.visualstudio.com/items?itemName=mechatroner.rainbow-csv">Rainbow CSV (<code>mechatroner.rainbow-csv</code>)</a> that enables you to open and visualize <a href="https://realpython.com/python-csv/">CSV files</a> in VS Code:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-rainbow-csv.c05a3d84ba99.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-rainbow-csv.c05a3d84ba99.png" width="2120" height="1004" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-rainbow-csv.c05a3d84ba99.png&amp;w=530&amp;sig=d944d4ac005f80b2874466d7f711ed0a105aecf8 530w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-rainbow-csv.c05a3d84ba99.png&amp;w=1060&amp;sig=1c4e7219d705715b03b98d804f7dc72abb2a69ca 1060w, https://files.realpython.com/media/vscode-rainbow-csv.c05a3d84ba99.png 2120w" sizes="75vw" alt="VS Code Rainbow CSV" data-asset="3812" /></a></figure>
<p>Each column is colorized, giving you a quick way to spot missing commas. You can also align all columns by running the <code>Rainbow CSV: Align CSV Columns</code> command from the Command Palette.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> If you&rsquo;re looking for an example CSV file to try this extension, you can pick a <a href="https://www.stats.govt.nz/large-datasets/csv-files-for-download/">CSV file for download</a> from the official statistics page of the New Zealand government.</p>
</div>
<p>The Rainbow CSV extension also comes with a <a href="https://rbql.org">Rainbow Query Language (RBQL)</a> query tool that lets you write RBQL queries on the CSV data to create filtered data sets:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-rainbow-rbql.5acfef1844dd.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-rainbow-rbql.5acfef1844dd.png" width="2680" height="1626" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-rainbow-rbql.5acfef1844dd.png&amp;w=670&amp;sig=ba14056eb8cd9840ebe862d8238923bd478f9871 670w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-rainbow-rbql.5acfef1844dd.png&amp;w=1340&amp;sig=a8305b3c21624cebed2c176db5eb98169bdbfc7b 1340w, https://files.realpython.com/media/vscode-rainbow-rbql.5acfef1844dd.png 2680w" sizes="75vw" alt="VS Code Rainbow RBQL" data-asset="3818" /></a></figure>
<p>You can access the RBQL console by running <code>Rainbow CSV: RBQL</code> in the Command Palette. After executing a query, you&rsquo;ll see the results in a new tab as a temporary CSV file that you can save and use for further data analysis work.</p>
<p>Throughout this tutorial, you&rsquo;ve installed a couple of useful extensions for VS Code. There are a lot of useful extensions available. In the final section of this tutorial, you&rsquo;ll learn about some extra extensions you haven&rsquo;t covered so far that you might also want to try out.</p>
</section></section><section class="section2" id="adding-bonus-extensions-to-visual-studio-code"><h2>Adding Bonus Extensions to Visual Studio Code<a class="headerlink" href="#adding-bonus-extensions-to-visual-studio-code" title="Permanent link"></a></h2>
<p>The <a href="https://marketplace.visualstudio.com">VS Code Marketplace</a> has thousands of extensions. The selection of extensions covers anything from language support, themes, spell checkers, and even mini-games.</p>
<p>In this tutorial so far, you&rsquo;ve covered a number of extensions that make Python development in Visual Studio Code more powerful. These last four extensions are optional&mdash;but could make your life easier.</p>
<section class="section3" id="code-spell-checker"><h3>Code Spell Checker<a class="headerlink" href="#code-spell-checker" title="Permanent link"></a></h3>
<p><a href="https://marketplace.visualstudio.com/items?itemName=streetsidesoftware.code-spell-checker">Code Spell Checker (<code>streetsidesoftware.code-spell-checker</code>)</a> is a spell checker that inspects variable names, text inside strings, and Python docstrings:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-codespell.aec631031c71.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-codespell.aec631031c71.png" width="1524" height="540" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-codespell.aec631031c71.png&amp;w=381&amp;sig=ddb9667b42a8f9ff35b9ea6f1313583841620741 381w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-codespell.aec631031c71.png&amp;w=762&amp;sig=6839ac676be780ea29680ef7b131cd50f563598b 762w, https://files.realpython.com/media/vscode-codespell.aec631031c71.png 1524w" sizes="75vw" alt="VS Code Spelling Extension" data-asset="3802" /></a></figure>
<p>The Code Spell Checker extension will highlight any suspected misspellings. You can either correct the spelling from the dictionary or add the word to a user or workspace dictionary.</p>
<p>The workspace dictionary will live inside the workspace folder, so you can check it into Git. The user dictionary is persisted across all your projects. If there are lots of keywords and phrases you use often, you can add them to the user dictionary.</p>
</section><section class="section3" id="docker"><h3>Docker<a class="headerlink" href="#docker" title="Permanent link"></a></h3>
<p>The <a href="https://marketplace.visualstudio.com/items?itemName=ms-azuretools.vscode-docker">Docker extension (<code>ms-azuretools.vscode-docker</code>)</a> makes it easy to create, manage, and debug containerized applications:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-docker-extension.3fea2e3a814e.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-docker-extension.3fea2e3a814e.png" width="3033" height="1690" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-docker-extension.3fea2e3a814e.png&amp;w=758&amp;sig=e2e8d19d8066c1c5187a57beda0f710028039a3f 758w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-docker-extension.3fea2e3a814e.png&amp;w=1516&amp;sig=6f7df2a5b23cdfb3ec2154012d7e4d4e327343d3 1516w, https://files.realpython.com/media/vscode-docker-extension.3fea2e3a814e.png 3033w" sizes="75vw" alt="VS Code docker extension" data-asset="3809" /></a></figure>
<p>The Docker extension goes beyond the Remote - Containers extension that you covered earlier. It gives you a UI to manage images, networks, container registries, volumes, and containers.</p>
</section><section class="section3" id="thunder-client"><h3>Thunder Client<a class="headerlink" href="#thunder-client" title="Permanent link"></a></h3>
<p><a href="https://marketplace.visualstudio.com/items?itemName=rangav.vscode-thunder-client">Thunder Client (<code>rangav.vscode-thunder-client</code>)</a> is an HTTP client and UI for VS Code designed to aid testing of REST APIs. If you&rsquo;re developing and testing APIs in frameworks like <a href="https://realpython.com/flask-connexion-rest-api/">Flask</a>, <a href="https://realpython.com/fastapi-python-web-apis/">FastAPI</a>, or <a href="https://realpython.com/django-rest-framework-quick-start/">Django Rest Framework</a>, you may already use a tool like <a href="https://www.postman.com">Postman</a> or <a href="https://curl.se">curl</a> to test your application.</p>
<p>Inside Thunder Client, you can create HTTP requests and send them to your API, manipulate headers, and set payloads of text, XML, and JSON:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-thunder-client.a101cf598909.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-thunder-client.a101cf598909.png" width="3125" height="1346" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-thunder-client.a101cf598909.png&amp;w=781&amp;sig=e8c8287b63436b00cd656cfd00b582237cac0fe8 781w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-thunder-client.a101cf598909.png&amp;w=1562&amp;sig=fbd51412570268b72aeadd1a19fa8048e99e3037 1562w, https://files.realpython.com/media/vscode-thunder-client.a101cf598909.png 3125w" sizes="75vw" alt="VS Code Thunder Client" data-asset="3810" /></a></figure>
<p>Thunder Client is a great alternative to Postman or curl, and since you can use it right inside of VS Code, you can avoid switching between applications when testing and developing your REST APIs.</p>
</section><section class="section3" id="vs-code-pets"><h3>VS Code Pets<a class="headerlink" href="#vs-code-pets" title="Permanent link"></a></h3>
<p><a href="https://marketplace.visualstudio.com/items?itemName=tonybaloney.vscode-pets">VS Code Pets (<code>tonybaloney.vscode-pets</code>)</a> is a fun extension that puts one or many small pets in your VS Code window:</p>
<figure class="js-lightbox"><a href="https://files.realpython.com/media/vscode-pets.42d5cfa82104.png" target="_blank"><img loading="lazy" class="img-fluid mx-auto d-block " src="https://files.realpython.com/media/vscode-pets.42d5cfa82104.png" width="934" height="632" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-pets.42d5cfa82104.png&amp;w=233&amp;sig=d6e0856342df9ef0d3aa7d903cecb917f266902a 233w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/vscode-pets.42d5cfa82104.png&amp;w=467&amp;sig=8cea846a34d60939c73413794d81632d64716b74 467w, https://files.realpython.com/media/vscode-pets.42d5cfa82104.png 934w" sizes="75vw" alt="VS Code pets" data-asset="3808" /></a></figure>
<p>You can customize the pets, customize their environments, and play games with them.</p>
<div class="alert alert-primary" role="alert">
<p><strong>Note:</strong> As the author of this tutorial, I&rsquo;ll say that this is a great extension&mdash;but I may be biased because I created it.</p>
</div>
<p>This is just a snapshot of the extensions on the marketplace. There are thousands more to discover for additional language support, UI improvements, or even <a href="https://marketplace.visualstudio.com/items?itemName=shyykoserhiy.vscode-spotify">Spotify Integration</a>.</p>
</section></section><section class="section2" id="conclusion"><h2>Conclusion<a class="headerlink" href="#conclusion" title="Permanent link"></a></h2>
<p>Visual Studio Code&rsquo;s Python tooling is evolving rapidly, and the team is putting out updates with bug fixes and new features monthly. Make sure you install any new updates to keep your environment on the latest and greatest.</p>
<p>In this tutorial, you&rsquo;ve seen an overview of some of the more advanced features in Visual Studio Code, the Python and Jupyter extensions, as well as some bonus extensions.</p>
<p><strong>You learned how to:</strong></p>
<ul>
<li>Customize your user interface with slick <strong>UI customizations</strong> and <strong>keyboard bindings</strong></li>
<li>Run and monitor Python tests by <strong>integrating your test framework</strong> into Visual Studio Code</li>
<li><strong>Lint and format code</strong> with Pylance and external linters</li>
<li><strong>Debug</strong> local and remote environments <strong>over SSH and Docker</strong></li>
<li>Spin up <strong>data science tools</strong> to work with <strong>Jupyter Notebooks</strong></li>
</ul>
<p>You can use this knowledge to put yourself on track to be a VS Code power user.</p>
<p>Play around with some of these extensions and test them out as you work on your next project. You&rsquo;ll find that some VS Code features will be more useful for you than others. Once you get a feel for some of the customizations and extensions, you&rsquo;ll likely find yourself in the VS Code docs looking for more or even <a href="https://code.visualstudio.com/api/get-started/your-first-extension">coding your own extensions</a>!</p>
</section>
<div class="text-center my-3">
<div class="jsCompletionStatusWidget btn-group mb-0">
<button title="Click to mark as completed" class="jsBtnCompletion btn btn-secondary border-right " style="border-top-right-radius: 0; border-bottom-right-radius: 0;" disabled>Mark as Completed</button>
<button title="Add bookmark" class="jsBtnBookmark btn btn-secondary border-left" disabled><i class="fa fa-fw fa-bookmark-o"></i></button>
</div>
</div>
</div>
<div class="card mt-4 mb-4 bg-secondary">
<p class="card-header h3 text-center bg-light">🐍 Python Tricks 💌</p>
<div class="card-body">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-7">
<p>Get a short &amp; sweet <strong>Python Trick</strong> delivered to your inbox every couple of days. No spam ever. Unsubscribe any time. Curated by the Real Python team.</p>
</div>
<div class="col-xs-12 col-sm-5">
<img class="img-fluid rounded mb-3" src="https://cdn.realpython.com/static/pytrick-dict-merge.4201a0125a5e.png" width="738" height="490" alt="Python Tricks Dictionary Merge">
</div>
</div>
<div class="row mb-3">
<form class="col-12" action="/optins/process/" method="post">
<input type="hidden" name="csrfmiddlewaretoken" value="AYJsonR7P8H5patGEZpOy9zUfbWcgGLZdeZTYML5r5LUsWuZHPXK3OA56KsjDkFe">
<input type="hidden" name="slug" value="static-python-tricks-footer">
<div class="form-group">
<input name="email" type="email" class="form-control form-control-lg" placeholder="Email Address" required>
</div>
<button name="submit" type="submit" class="btn btn-primary btn-lg btn-block">Send Me Python Tricks »</button>
</form>
</div>
</div>
</div>
</div>
<div class="card mt-3" id="author">
<p class="card-header h3">About <strong>Anthony Shaw</strong></p>
<div class="card-body">
<div class="container p-0">
<div class="row">
<div class="col-12 col-md-3 align-self-center">
<a href="/team/ashaw/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=551&amp;h=551&amp;mode=crop&amp;sig=c05bc24bc6e85059dc301292b3cbd11a77da9a99" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=137&amp;h=137&amp;mode=crop&amp;sig=c4a3dc8d9701357dd90d57ff3edeb72d4fe08fda 137w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=275&amp;h=275&amp;mode=crop&amp;sig=9a0e6868a262e25e0989a983ea9e74ad8a724fbb 275w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=551&amp;h=551&amp;mode=crop&amp;sig=c05bc24bc6e85059dc301292b3cbd11a77da9a99 551w" sizes="25vw" width="551" height="551" class="d-block d-md-none rounded-circle img-fluid w-33 mb-0 mx-auto" alt="Anthony Shaw"></a>
<a href="/team/ashaw/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=551&amp;h=551&amp;mode=crop&amp;sig=c05bc24bc6e85059dc301292b3cbd11a77da9a99" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=137&amp;h=137&amp;mode=crop&amp;sig=c4a3dc8d9701357dd90d57ff3edeb72d4fe08fda 137w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=275&amp;h=275&amp;mode=crop&amp;sig=9a0e6868a262e25e0989a983ea9e74ad8a724fbb 275w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/10995490_10152772557676353_1442757472697890998_n.e88e3d7b17c7.jpg&amp;w=551&amp;h=551&amp;mode=crop&amp;sig=c05bc24bc6e85059dc301292b3cbd11a77da9a99 551w" sizes="25vw" width="551" height="551" class="d-none d-md-block rounded-circle img-fluid w-100 mb-0" alt="Anthony Shaw"></a>
</div>
<div class="col mt-3">
<p>Anthony is an avid Pythonista and writes for Real Python. Anthony is a Fellow of the Python Software Foundation and member of the Open-Source Apache Foundation.</p>
<a href="/team/ashaw/" class="card-link">» More about Anthony</a>
</div>
</div>
</div>
</div>
<hr class="my-0">
<div class="card-body pb-0">
<div class="container">
<div class="row">
<p><em>Each tutorial at Real Python is created by a team of developers so that it meets our high quality standards. The team members who worked on this tutorial are:</em></p>
</div>
<div class="row align-items-center w-100 mx-auto">
<div class="col-4 col-sm-2 align-self-center">
<a href="/team/asantos/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/asantos-avatar.888c78fffab3.jpg&amp;w=700&amp;h=700&amp;mode=crop&amp;sig=be17609cd7f6a4cd249ff61e186b3ad1aece949c" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/asantos-avatar.888c78fffab3.jpg&amp;w=175&amp;h=175&amp;mode=crop&amp;sig=30253487c673fd67bb45ea6bef95b3c57e115e46 175w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/asantos-avatar.888c78fffab3.jpg&amp;w=350&amp;h=350&amp;mode=crop&amp;sig=a43bd9ea30a6f61a4fc2451ab9abfc6faec8a2c0 350w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/asantos-avatar.888c78fffab3.jpg&amp;w=700&amp;h=700&amp;mode=crop&amp;sig=be17609cd7f6a4cd249ff61e186b3ad1aece949c 700w" sizes="10vw" width="551" height="551" class="rounded-circle img-fluid w-100" alt="Aldren Santos"></a>
</div>
<div class="col pl-0 d-none d-sm-block">
<a href="/team/asantos/" class="card-link small"><p>Aldren</p></a>
</div>
<div class="col-4 col-sm-2 align-self-center">
<a href="/team/bzaczynski/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profile-picture.9b78351e1462.jpg&amp;w=900&amp;h=900&amp;mode=crop&amp;sig=84695876e8b66be5e91aa5eb72f25a3fb4dcceeb" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profile-picture.9b78351e1462.jpg&amp;w=225&amp;h=225&amp;mode=crop&amp;sig=8e1a0d84149944be3c2615404fb46e7da001c17f 225w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profile-picture.9b78351e1462.jpg&amp;w=450&amp;h=450&amp;mode=crop&amp;sig=2e7c93ebefa8a958432160f29cd4a09c889ae8d3 450w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profile-picture.9b78351e1462.jpg&amp;w=900&amp;h=900&amp;mode=crop&amp;sig=84695876e8b66be5e91aa5eb72f25a3fb4dcceeb 900w" sizes="10vw" width="551" height="551" class="rounded-circle img-fluid w-100" alt="Bartosz Zaczyński"></a>
</div>
<div class="col pl-0 d-none d-sm-block">
<a href="/team/bzaczynski/" class="card-link small"><p>Bartosz</p></a>
</div>
<div class="col-4 col-sm-2 align-self-center">
<a href="/team/gahjelle/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/gahjelle.470149ee709e.jpg&amp;w=800&amp;h=800&amp;mode=crop&amp;sig=e9b761c6cf1359953014dba05554f5424eb116e1" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/gahjelle.470149ee709e.jpg&amp;w=200&amp;h=200&amp;mode=crop&amp;sig=c6390201e73d3e09429d73da5bb29c17ab10403a 200w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/gahjelle.470149ee709e.jpg&amp;w=400&amp;h=400&amp;mode=crop&amp;sig=fcea459ee24a7b320573cadee324cf75509dc1d6 400w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/gahjelle.470149ee709e.jpg&amp;w=800&amp;h=800&amp;mode=crop&amp;sig=e9b761c6cf1359953014dba05554f5424eb116e1 800w" sizes="10vw" width="551" height="551" class="rounded-circle img-fluid w-100" alt="Geir Arne Hjelle"></a>
</div>
<div class="col pl-0 d-none d-sm-block">
<a href="/team/gahjelle/" class="card-link small"><p>Geir Arne</p></a>
</div>
</div>
<div class="row align-items-center w-100 mx-auto">
<div class="col-4 col-sm-2 align-self-center">
<a href="/team/mbreuss/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/martin_breuss_python_square.efb2b07faf9f.jpg&amp;w=456&amp;h=456&amp;mode=crop&amp;sig=f73f6ae668249c7ab9ff74c61ea5ae7c5d360d54" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/martin_breuss_python_square.efb2b07faf9f.jpg&amp;w=114&amp;h=114&amp;mode=crop&amp;sig=1a2362c5f4fdf6550020fa2edf1cbed47bffdf53 114w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/martin_breuss_python_square.efb2b07faf9f.jpg&amp;w=228&amp;h=228&amp;mode=crop&amp;sig=83e21635985e51035377eed031afa8feae263333 228w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/martin_breuss_python_square.efb2b07faf9f.jpg&amp;w=456&amp;h=456&amp;mode=crop&amp;sig=f73f6ae668249c7ab9ff74c61ea5ae7c5d360d54 456w" sizes="10vw" width="551" height="551" class="rounded-circle img-fluid w-100" alt="Martin Breuss"></a>
</div>
<div class="col pl-0 d-none d-sm-block">
<a href="/team/mbreuss/" class="card-link small"><p>Martin</p></a>
</div>
<div class="col-4 col-sm-2 align-self-center">
<a href="/team/sparker/"><img loading="lazy" src="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profpic_sp.a008488b6af0.jpeg&amp;w=800&amp;h=800&amp;mode=crop&amp;sig=ec9f8b060e53c9b35339584491f286fd52c11452" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profpic_sp.a008488b6af0.jpeg&amp;w=200&amp;h=200&amp;mode=crop&amp;sig=ce5407d34a490d4daf29ad57e74fd3870dd28774 200w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profpic_sp.a008488b6af0.jpeg&amp;w=400&amp;h=400&amp;mode=crop&amp;sig=dfd70d0dde444f036864e5cc145df9b18fbae649 400w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/profpic_sp.a008488b6af0.jpeg&amp;w=800&amp;h=800&amp;mode=crop&amp;sig=ec9f8b060e53c9b35339584491f286fd52c11452 800w" sizes="10vw" width="551" height="551" class="rounded-circle img-fluid w-100" alt="Sadie Parker"></a>
</div>
<div class="col pl-0 d-none d-sm-block">
<a href="/team/sparker/" class="card-link small"><p>Sadie</p></a>
</div>
<div class="col-4 col-sm-2 align-self-center"></div>
<div class="col pl-0 d-none d-sm-block"></div>
</div>
</div>
</div>
</div>
<div class="bg-light rounded py-4 my-4 shadow shadow-sm mx-n2">
<div class="col-12 text-center d-block d-md-none">
<p class="h2 mb-3">Master <u><span class="marker-highlight">Real-World Python Skills</mark></u> With Unlimited Access to Real&nbsp;Python</p>
<p class="mb-1"><img class="w-75" src="https://cdn.realpython.com/static/videos/lesson-locked.f5105cfd26db.svg" width="510" height="260"></p>
<p class="mx-auto w-75 mb-3 small"><strong>Join us and get access to hundreds of tutorials, hands-on video courses, and a community of expert&nbsp;Pythonistas:</strong></p>
<p class="mb-0"><a href="/account/join/?utm_source=rp_article_footer&utm_content=advanced-visual-studio-code-python" class="btn btn-primary btn-sm px-4 mb-0">Level Up Your Python Skills »</a>
</div>
<div class="col-12 text-center d-none d-md-block">
<p class="h2 mb-2">Master <u><span class="marker-highlight">Real-World Python Skills</span></u><br>With Unlimited Access to Real&nbsp;Python</p>
<p class="mb-2"><img class="w-50 mb-2" src="https://cdn.realpython.com/static/videos/lesson-locked.f5105cfd26db.svg" width="510" height="260"></p>
<p class="mx-auto w-50 mb-3"><strong>Join us and get access to hundreds of tutorials, hands-on video courses, and a community of expert Pythonistas:</strong></p>
<p><a href="/account/join/?utm_source=rp_article_footer&utm_content=advanced-visual-studio-code-python" class="btn btn-primary btn-lg px-4">Level Up Your Python Skills »</a>
</div>
</div>
<div class="card mt-4" id="reader-comments">
<p class="card-header h3">What Do You Think?</p>
<div class="text-center mt-3 mb-0 p-0">
<span>
<a target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet/?text=Check out this %23Python tutorial: Advanced%20Visual%20Studio%20Code%20for%20Python%20Developers by @realpython&url=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-twitter text-light mb-1"><i class="mr-1 fa fa-twitter text-light"></i>Tweet</a>
<a target="_blank" rel="nofollow" href="https://facebook.com/sharer/sharer.php?u=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-facebook text-light mb-1"><i class="mr-1 fa fa-facebook text-light"></i>Share</a>
<a target="_blank" rel="nofollow" href="mailto:?subject=Python article for you&body=Check out this Python tutorial:%0A%0AAdvanced%20Visual%20Studio%20Code%20for%20Python%20Developers%0A%0Ahttps%3A//realpython.com/advanced-visual-studio-code-python/" class="badge badge-red text-light mb-1"><i class="mr-1 fa fa-envelope text-light"></i>Email</a>
</span>
</div>
<div class="card-body">
<div class="alert alert-dark">
<p class="mb-0"><strong>Real Python Comment Policy:</strong> The most useful comments are those written with the goal of learning from or helping out other readers—after reading the whole article and all the earlier comments. Complaints and insults generally won’t make the cut here.</p>
</div>
<p>What’s your #1 takeaway or favorite thing you learned? How are you going to put your newfound skills to use? Leave a comment below and let us know.</p>
<div class="mb-4" id="disqus_thread">
</div>
</div>
</div>
<div class="card mt-4 mb-4">
<p class="card-header h3">Keep Learning</p>
<div class="card-body">
<p class="mb-0">Related Tutorial Categories:
<a href="/tutorials/advanced/" class="badge badge-light text-muted">advanced</a>
<a href="/tutorials/python/" class="badge badge-light text-muted">python</a>
<a href="/tutorials/tools/" class="badge badge-light text-muted">tools</a>
</p>
</div>
</div>
<div class="modal fade" tabindex="-1" role="dialog" id="rprw">
<div class="modal-dialog modal-lg modal-dialog-centered" role="document">
<div class="modal-content">
<div class="modal-header border-0 mt-3">
<div class="col-12 modal-title text-center">
<h2 class="my-0 mx-5">Keep reading Real&nbsp;Python by creating a free account or signing&nbsp;in:</h2>
</div>
</div>
<div class="modal-body bg-light">
<div class="col-12 text-center">
<p class="mb-2 mt-3"><a href="/account/signup/?intent=continue_reading&utm_source=rp&utm_medium=web&utm_campaign=rwn&utm_content=v1&next=%2Fadvanced-visual-studio-code-python%2F"><img class="w-50 mb-2" src="https://cdn.realpython.com/static/videos/lesson-locked.f5105cfd26db.svg" width="510" height="260" alt="Keep reading"></a></p>
<p><a href="/account/signup/?intent=continue_reading&utm_source=rp&utm_medium=web&utm_campaign=rwn&utm_content=v1&next=%2Fadvanced-visual-studio-code-python%2F" class="btn btn-primary btn-lg px-5"></i>Continue »</a></a>
</div>
</div>
<div class="modal-footer border-0">
<p class="text-center text-muted mt-2 mb-1">Already have an account? <a href="/account/login/?next=/advanced-visual-studio-code-python/">Sign-In</a></p>
</div>
</div>
</div>
</div>
<script src="https://cdn.realpython.com/static/frontend/reader/rw.38bf29157dfe.js" async></script>
</div>
<aside class="col-md-7 col-lg-4">
<div class="card mb-3 bg-secondary">
<form class="card-body" action="/optins/process/" method="post">
<div class="form-group">
<p class="h5 text-muted text-center">— FREE Email Series —</p>
<p class="h3 text-center">🐍 Python Tricks 💌</p>
<p><img class="img-fluid rounded" src="https://cdn.realpython.com/static/pytrick-dict-merge.4201a0125a5e.png" width="738" height="490" alt="Python Tricks Dictionary Merge"></p>
</div>
<div class="form-group">
<input type="hidden" name="csrfmiddlewaretoken" value="AYJsonR7P8H5patGEZpOy9zUfbWcgGLZdeZTYML5r5LUsWuZHPXK3OA56KsjDkFe">
<input type="hidden" name="slug" value="static-python-tricks-sidebar">
<input type="email" class="form-control form-control-md" name="email" placeholder="Email&hellip;" required>
</div>
<button type="submit" name="submit" class="btn btn-primary btn-md btn-block">Get Python Tricks »</button>
<p class="mb-0 mt-2 text-muted text-center">🔒 No spam. Unsubscribe any time.</p>
</form>
</div>
<div class="sidebar-module sidebar-module-inset border">
<p class="h4"><a class="link-unstyled" href="/tutorials/all/">All Tutorial Topics</a></p>
<a href="/tutorials/advanced/" class="badge badge-light text-muted">advanced</a>
<a href="/tutorials/api/" class="badge badge-light text-muted">api</a>
<a href="/tutorials/basics/" class="badge badge-light text-muted">basics</a>
<a href="/tutorials/best-practices/" class="badge badge-light text-muted">best-practices</a>
<a href="/tutorials/community/" class="badge badge-light text-muted">community</a>
<a href="/tutorials/databases/" class="badge badge-light text-muted">databases</a>
<a href="/tutorials/data-science/" class="badge badge-light text-muted">data-science</a>
<a href="/tutorials/devops/" class="badge badge-light text-muted">devops</a>
<a href="/tutorials/django/" class="badge badge-light text-muted">django</a>
<a href="/tutorials/docker/" class="badge badge-light text-muted">docker</a>
<a href="/tutorials/flask/" class="badge badge-light text-muted">flask</a>
<a href="/tutorials/front-end/" class="badge badge-light text-muted">front-end</a>
<a href="/tutorials/gamedev/" class="badge badge-light text-muted">gamedev</a>
<a href="/tutorials/gui/" class="badge badge-light text-muted">gui</a>
<a href="/tutorials/intermediate/" class="badge badge-light text-muted">intermediate</a>
<a href="/tutorials/machine-learning/" class="badge badge-light text-muted">machine-learning</a>
<a href="/tutorials/projects/" class="badge badge-light text-muted">projects</a>
<a href="/tutorials/python/" class="badge badge-light text-muted">python</a>
<a href="/tutorials/testing/" class="badge badge-light text-muted">testing</a>
<a href="/tutorials/tools/" class="badge badge-light text-muted">tools</a>
<a href="/tutorials/web-dev/" class="badge badge-light text-muted">web-dev</a>
<a href="/tutorials/web-scraping/" class="badge badge-light text-muted">web-scraping</a>
</div>
<div class="sidebar-module sidebar-module-inset p-0" style="overflow:hidden;">
<div style="display:block;position:relative;">
<div style="display:block;width:100%;padding-top:100%;"></div>
<div class="rpad" data-unit="1x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div>
</div>
</div>
<div class="sidebar-sticky ">
<div class="bg-light sidebar-module sidebar-module-inset" id="sidebar-toc">
<p class="h4 text-muted"><a class="link-unstyled" href="#toc">Table of Contents</a></p>
<div class="toc">
<ul>
<li><a href="#mastering-the-visual-studio-code-user-interface">Mastering the Visual Studio Code User Interface</a><ul>
<li><a href="#keyboard-shortcuts">Keyboard Shortcuts</a></li>
<li><a href="#customizing-the-user-interface">Customizing the User Interface</a></li>
<li><a href="#setting-up-your-terminal">Setting Up Your Terminal</a></li>
<li><a href="#team-settings-vs-personal-settings">Team Settings vs Personal Settings</a></li>
</ul>
</li>
<li><a href="#linting-and-formatting">Linting and Formatting</a><ul>
<li><a href="#setting-up-pylance">Setting Up Pylance</a></li>
<li><a href="#setting-format-and-lint-on-save">Setting Format and Lint on Save</a></li>
</ul>
</li>
<li><a href="#testing-your-python-code-in-visual-studio-code">Testing Your Python Code in Visual Studio Code</a><ul>
<li><a href="#configuring-test-integration">Configuring Test Integration</a></li>
<li><a href="#executing-tests">Executing Tests</a></li>
</ul>
</li>
<li><a href="#using-the-visual-studio-code-tasks-system">Using the Visual Studio Code Tasks System</a><ul>
<li><a href="#using-tasks-to-compile-wheels">Using Tasks to Compile Wheels</a></li>
<li><a href="#using-tasks-for-django">Using Tasks for Django</a></li>
<li><a href="#chaining-tasks">Chaining Tasks</a></li>
<li><a href="#using-tasks-to-run-tox">Using Tasks to Run Tox</a></li>
<li><a href="#using-the-task-explorer-extension">Using the Task Explorer Extension</a></li>
</ul>
</li>
<li><a href="#debugging-your-python-scripts-in-visual-studio-code">Debugging Your Python Scripts in Visual Studio Code</a><ul>
<li><a href="#setting-watches">Setting Watches</a></li>
<li><a href="#configuring-a-launch-file">Configuring a Launch File</a></li>
</ul>
</li>
<li><a href="#mastering-remote-development">Mastering Remote Development</a><ul>
<li><a href="#remote-development-with-containers">Remote Development With Containers</a></li>
<li><a href="#remote-development-with-ssh">Remote Development With SSH</a></li>
<li><a href="#remote-development-with-wsl">Remote Development With WSL</a></li>
</ul>
</li>
<li><a href="#working-with-data-science-tools">Working With Data Science Tools</a><ul>
<li><a href="#installing-the-jupyter-notebook-extension">Installing the Jupyter Notebook Extension</a></li>
<li><a href="#getting-started-with-jupyter-notebooks-in-vs-code">Getting Started With Jupyter Notebooks in VS Code</a></li>
<li><a href="#using-the-data-viewer">Using the Data Viewer</a></li>
<li><a href="#using-the-rainbow-csv-extension">Using the Rainbow CSV Extension</a></li>
</ul>
</li>
<li><a href="#adding-bonus-extensions-to-visual-studio-code">Adding Bonus Extensions to Visual Studio Code</a><ul>
<li><a href="#code-spell-checker">Code Spell Checker</a></li>
<li><a href="#docker">Docker</a></li>
<li><a href="#thunder-client">Thunder Client</a></li>
<li><a href="#vs-code-pets">VS Code Pets</a></li>
</ul>
</li>
<li><a href="#conclusion">Conclusion</a></li>
</ul>
</div>
</div>
<div class="sidebar-module sidebar-module-inset text-center my-3 py-0">
<div class="jsCompletionStatusWidget btn-group mb-0">
<button title="Click to mark as completed" class="jsBtnCompletion btn btn-secondary border-right " style="border-top-right-radius: 0; border-bottom-right-radius: 0;" disabled>Mark as Completed</button>
<button title="Add bookmark" class="jsBtnBookmark btn btn-secondary border-left" disabled><i class="fa fa-fw fa-bookmark-o"></i></button>
</div>
</div>
<div class="sidebar-module sidebar-module-inset text-center my-3 py-0">
<span>
<a target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet/?text=Check out this %23Python tutorial: Advanced%20Visual%20Studio%20Code%20for%20Python%20Developers by @realpython&url=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-twitter text-light mb-1"><i class="mr-1 fa fa-twitter text-light"></i>Tweet</a>
<a target="_blank" rel="nofollow" href="https://facebook.com/sharer/sharer.php?u=https%3A//realpython.com/advanced-visual-studio-code-python/" class="mr-1 badge badge-facebook text-light mb-1"><i class="mr-1 fa fa-facebook text-light"></i>Share</a>
<a target="_blank" rel="nofollow" href="mailto:?subject=Python article for you&body=Check out this Python tutorial:%0A%0AAdvanced%20Visual%20Studio%20Code%20for%20Python%20Developers%0A%0Ahttps%3A//realpython.com/advanced-visual-studio-code-python/" class="badge badge-red text-light mb-1"><i class="mr-1 fa fa-envelope text-light"></i>Email</a>
</span>
</div>
<div class="sidebar-module sidebar-module-inset p-0" style="overflow:hidden;">
<div style="display:block;position:relative;">
<div style="display:block;width:100%;padding-top:25%;"></div>
<div class="rpad" data-unit="4x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div>
</div>
</div>
</div>
</aside>
</div>
</div>
<div class="modal fade" id="modal-python-mastery-course" tabindex="-1" role="dialog" aria-hidden="true">
<div class="modal-dialog modal-dialog-centered modal-lg" role="document">
<div class="modal-content">
<div class="modal-header bg-light pt-3 pb-2">
<div class="container-fluid">
<div class="row">
<div class="col-12">
<div class="progress" style="height: .5rem;">
<div class="progress-bar progress-bar-striped progress-bar-animated w-50" role="progressbar"></div>
</div>
</div>
<div class="col-12">
<p class="text-muted text-center mb-0 mt-2">Almost there! Complete this form and click the button below to gain instant access:</p>
</div>
</div>
</div>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button>
</div>
<div class="modal-body m-4">
<div class="container-fluid">
<div class="row align-items-center">
<div class="col-12 col-lg-4 mb-4">
<img class="img-fluid rounded" src="https://files.realpython.com/media/python-logo.8eb72ea6927b.png" width="1000" height="1000" srcset="https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/python-logo.8eb72ea6927b.png&amp;w=250&amp;sig=3922247197a4a17add6954dd288123a4df30e55a 250w, https://robocrop.realpython.net/?url=https%3A//files.realpython.com/media/python-logo.8eb72ea6927b.png&amp;w=500&amp;sig=40c3b1b474ae94aec528188714ba5878a77362ea 500w, https://files.realpython.com/media/python-logo.8eb72ea6927b.png 1000w" sizes="50vw" alt="Python Logo">
</div>
<div class="col">
<p class="text-center h3 mb-4">5 Thoughts On Python Mastery</p>
<form class="col-12" action="/optins/process/" method="post">
<input type="hidden" name="csrfmiddlewaretoken" value="AYJsonR7P8H5patGEZpOy9zUfbWcgGLZdeZTYML5r5LUsWuZHPXK3OA56KsjDkFe">
<input type="hidden" name="slug" value="python-mastery-course">
<div class="form-group">
<input type="email" name="email" class="form-control" placeholder="Email Address" required autofocus>
</div>
<button name="submit" type="submit" class="btn btn-primary btn-block text-wrap">Start the Class »</button>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer class="footer">
<div class="container">
<div class="w-75 mx-auto mt-4 mb-0">
<div style="display:block;position:relative;">
<div style="display:block;width:100%;padding-top:12.5%;"></div>
<div class="rpad rounded border" data-unit="8x1" style="position:absolute;left:0;top:0;right:0;bottom:0;overflow:hidden;"></div>
</div>
<a class="small text-muted" href="/account/join/" rel="nofollow"> <i class="fa fa-info-circle" aria-hidden="true"> </i> Remove ads</a>
</div>
<p class="text-center text-muted w-75 mx-auto">© 2012–2021 Real Python&nbsp;⋅ <a href="/newsletter/">Newsletter</a>&nbsp;⋅ <a href="/podcasts/rpp/">Podcast</a>&nbsp;⋅ <a href="https://www.youtube.com/realpython">YouTube</a>&nbsp;⋅ <a href="https://twitter.com/realpython">Twitter</a>&nbsp;⋅ <a href="https://facebook.com/LearnRealPython">Facebook</a>&nbsp;⋅ <a href="https://www.instagram.com/realpython/">Instagram</a>&nbsp;⋅ <a href="/">Python&nbsp;Tutorials</a>&nbsp;⋅ <a href="/search">Search</a>&nbsp;⋅ <a href="/privacy-policy/">Privacy Policy</a>&nbsp;⋅ <a href="/energy-policy/" class="text-success active">Energy Policy</a>&nbsp;⋅ <a href="/sponsorships/">Advertise</a>&nbsp;⋅ <a href="/contact/">Contact</a><br>❤️ Happy Pythoning!</p>
</div>
</footer>
<script>
      (function(document, history, location) {
        var HISTORY_SUPPORT = !!(history && history.pushState);

        var anchorScrolls = {
          ANCHOR_REGEX: /^#[^ ]+$/,
          OFFSET_HEIGHT_PX: 120,

          /**
           * Establish events, and fix initial scroll position if a hash is provided.
           */
          init: function() {
            this.scrollToCurrent();
            window.addEventListener('hashchange', this.scrollToCurrent.bind(this));
            document.body.addEventListener('click', this.delegateAnchors.bind(this));
          },

          /**
           * Return the offset amount to deduct from the normal scroll position.
           * Modify as appropriate to allow for dynamic calculations
           */
          getFixedOffset: function() {
            return this.OFFSET_HEIGHT_PX;
          },

          /**
           * If the provided href is an anchor which resolves to an element on the
           * page, scroll to it.
           * @param  {String} href
           * @return {Boolean} - Was the href an anchor.
           */
          scrollIfAnchor: function(href, pushToHistory) {
            var match, rect, anchorOffset;

            if(!this.ANCHOR_REGEX.test(href)) {
              return false;
            }

            match = document.getElementById(href.slice(1));

            if(match) {
              rect = match.getBoundingClientRect();
              anchorOffset = window.pageYOffset + rect.top - this.getFixedOffset();
              window.scrollTo(window.pageXOffset, anchorOffset);

              // Add the state to history as-per normal anchor links
              if(HISTORY_SUPPORT && pushToHistory) {
                history.pushState({}, document.title, location.pathname + href);
              }
            }

            return !!match;
          },

          /**
           * Attempt to scroll to the current location's hash.
           */
          scrollToCurrent: function() {
            this.scrollIfAnchor(window.location.hash);
          },

          /**
           * If the click event's target was an anchor, fix the scroll position.
           */
          delegateAnchors: function(e) {
            var elem = e.target;

            // 
            if (elem.dataset.toggle === "tab") {
              return;
            }

            if(
              elem.nodeName === 'A' &&
              this.scrollIfAnchor(elem.getAttribute('href'), true)
            ) {
              e.preventDefault();
            }
          }
        };

        window.addEventListener(
          'DOMContentLoaded', anchorScrolls.init.bind(anchorScrolls)
        );
      })(window.document, window.history, window.location);
    </script>
<script src="https://cdn.realpython.com/static/jquery.min.8fb8fee4fcc3.js"></script>
<script src="https://cdn.realpython.com/static/popper.min.1022eaf388cc.js"></script>
<script src="https://cdn.realpython.com/static/bootstrap.min.f0c2bcf5ef0c.js"></script>
<script>
    (function() {
      document.querySelectorAll(".js-search-form-submit").forEach(function(el) {
        el.addEventListener("click", function(e) {
          e.preventDefault();
          e.currentTarget.parentElement.submit();
        })
      });
    })();
    </script>
<script src="https://cdn.realpython.com/static/frontend/reader/repl-toggle.de6c7bf44788.js" async></script>
<script src="https://cdn.realpython.com/static/frontend/reader/lightbox.49cdac39212e.js" async></script>
<script>window.rp_prop_id = '58946116052';</script>
<script src="https://srv.realpython.net/tag.js" async></script>
<script src="https://cdn.realpython.com/static/frontend/reader/toc-refresh.76a102c7d921.js" async></script>
<script id="js-context" type="application/json">{"is_completed": false, "is_bookmarked": false, "api_article_bookmark_url": "/api/v1/articles/advanced-visual-studio-code-python/bookmark/", "api_article_completion_status_url": "/api/v1/articles/advanced-visual-studio-code-python/completion_status/"}</script>
<script src="https://cdn.realpython.com/static/frontend/reader/completion-status.352d07abd84a.js" async></script>
<script id="dsq-count-scr" src="https://realpython.disqus.com/count.js" async></script>
<script>
      var disqus_config = function () {
        this.page.url = 'https://realpython.com/advanced-visual-studio-code-python/';
        this.page.identifier = 'https://realpython.com/advanced-visual-studio-code-python/';
        this.callbacks.onReady = [function() {
          if (window.onDisqusReady) {
            window.onDisqusReady();
          }
        }];
      };
      var disqus_script_url = 'https://realpython.disqus.com/embed.js';
    </script>
<script src="https://cdn.realpython.com/static/frontend/reader/lazy-disqus.07ee9079f4a3.js" defer></script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
<script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(function() {
      OneSignal.init({
        appId: "c0081e20-a523-42bb-b0ac-04c5a9e8bf40"
      });
    });
  </script>
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "Article",
    "headline": "Advanced Visual Studio Code for Python Developers",
    
    "image": {
      "@type": "ImageObject",
      "url": "https://files.realpython.com/media/VSCode--Python-for-Advanced-Users_Watermarked.84ce081f2abc.jpeg",
      "width": 1920,
      "height": 1080
    },
    
    "mainEntityOfPage": {
      "@type": "WebPage",
      "@id": "https://realpython.com/advanced-visual-studio-code-python/"
    },
    "datePublished": "2021-11-10T14:00:00+00:00",
    "dateModified": "2021-11-12T11:22:19.512883+00:00",
     "publisher": {
      "@type": "Organization",
      "name": "Real Python",
      "logo": {
        "@type": "ImageObject",
        "url": "https://cdn.realpython.com/static/real-python-logo-square-tiny.b2452b6d3823.png",
        "width": 60,
        "height": 60
      }
    },
    "author": {
      "@type": "Organization",
      "name": "Real Python",
      "url": "https://realpython.com",
      "logo": "https://cdn.realpython.com/static/real-python-logo-square.146e987bf77c.png"
    },
    "description": "In this tutorial, you\u0027ll learn how you can configure, extend, and optimize Visual Studio Code for a more effective and productive Python development environment. By digging into this customizable code editor and IDE, you\u0027ll put yourself on track to be a VS Code power user."
  }
  </script>
<script>
  var _dcq = _dcq || [];
  var _dcs = _dcs || {};
  _dcs.account = '6214500';

  (function() {
    var dc = document.createElement('script');
    dc.type = 'text/javascript'; dc.async = true;
    dc.src = '//tag.getdrip.com/6214500.js';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(dc, s);
  })();
</script>
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '2220911568135371');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=2220911568135371&ev=PageView&noscript=1"
/></noscript>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6c43550179bf5d8c',m:'vYv5nRC20U234WAenrzQSmLJk6bqnGjzXAR_48ximJU-1640616320-0-AVZRx/PArfIcUl5PEW/n5ZIzGslY4YGZs6+hfenu4FUGb0nfIRYIvzWnEgcos5+mQ16qhx3bKIqzNYbr7Jk15XhPSVjY/cP0/ouJyLcwOkWqeINDkJnvtpgXHdeKVdvAHAvg1rDqNWDpMfQcQnpfAxG2Ry1jEYKBWE4Qrlg6hASa',s:[0xc4d8f9ba27,0xf770e0a9d8],}})();</script></body>
</html>
